1 { pkgs, lib, config, ... }:
4 [ <nixpkgs/nixos/modules/installer/scan/not-detected.nix>
7 hardware.cpu.amd.updateMicrocode = true;
12 "vm.vfs_cache_pressure" = 50;
23 "/dev/disk/by-id/ata-Samsung_SSD_840_EVO_250GB_S1DBNSAF340110R"
27 { devices = [ "${disk_id}" ];
28 path = "/boot${bootnum}";
35 canTouchEfiVariables = true;
36 efiSysMountPoint = "/boot/efi";
37 efiInstallAsRemovable = false;
43 availableKernelModules = [
50 # Made the AES modules available at initrd,
51 # to speedup the deciphering of the root.
59 boot.kernelModules = [ ];
60 boot.extraModulePackages = [ ];
64 "console=ttyS0,115200n8"
65 "zfs.zfs_arc_max=262144000" # 250Mo
69 { device = "/dev/disk/by-uuid/dc3c5387-17d2-43b3-bfa2-bf73afacca07";
73 fileSystems."/boot/efi" =
74 { device = "/dev/disk/by-uuid/62E6-E65F";
79 [ { device = "/dev/disk/by-partuuid/6b1eaa35-776b-4e60-b21e-7bcee535dd8b";
82 cipher = "aes-xts-plain64";
83 source = "/dev/urandom";
88 nix.maxJobs = lib.mkDefault 4;
89 powerManagement.cpuFreqGovernor = lib.mkDefault "ondemand";
92 systemPackages = with pkgs; [