]> Git — Sourcephile - sourcephile-nix.git/blob - machines/losurdo/system.nix
nix: servers.nix -> machines.nix
[sourcephile-nix.git] / machines / losurdo / system.nix
1 { pkgs, lib, config, ... }:
2 let
3 inherit (config) networking;
4 inherit (config.security) pass;
5 in
6 {
7 # This value determines the NixOS release with which your system is to be
8 # compatible, in order to avoid breaking some software such as database servers.
9 # You should change this only after NixOS release notes say you should.
10 system.stateVersion = "19.09"; # Did you read the comment?
11
12 # Avoid the use of systemd-run --user --scope tmux
13 # and let mosh work smoothly.
14 services.logind.killUserProcesses = false;
15
16
17 services.unbound.enable = true;
18
19 environment.systemPackages = with pkgs; [
20 cryptsetup
21 direnv
22 file
23 fio
24 gdb
25 git
26 gptfdisk
27 #hey
28 home-manager
29 lm_sensors
30 rsync
31 smartctl-tbw
32 socat
33 sanoid
34 #iptables-nftables-compat
35 gnupg
36 miniupnpc
37 ];
38 }