]> Git — Sourcephile - sourcephile-nix.git/blob - machines/mermet/system.nix
nix: servers.nix -> machines.nix
[sourcephile-nix.git] / machines / mermet / system.nix
1 { pkgs, lib, config, ... }:
2 {
3 # This value determines the NixOS release with which your system is to be
4 # compatible, in order to avoid breaking some software such as database servers.
5 # You should change this only after NixOS release notes say you should.
6 system.stateVersion = "19.09"; # Did you read the comment?
7
8 services.unbound.enable = true;
9
10 environment.systemPackages = with pkgs; [
11 cryptsetup
12 direnv
13 file
14 fio
15 gdb
16 git
17 gptfdisk
18 #hey
19 home-manager
20 lm_sensors
21 rsync
22 smartctl-tbw
23 socat
24 thttpd
25 #iptables-nftables-compat
26 ];
27 }