3 services.openssh.settings.LogLevel = "VERBOSE";
4 services.postgresql.logLinePrefix = "%h ";
6 systemd.services.nftables.postStart = '' systemctl reload fail2ban '';
10 banaction = "nftables-multiport";
11 banaction-allports = "nftables-allports";
15 formula = "ban.Time * (1 << min(ban.Count, 20)) * banFactor";
20 packageFirewall = pkgs.nftables;
31 hosts.mermet._module.args.ipv4
32 "losurdo.sourcephile.fr"
42 postgresql.settings = {
45 filter = "postgresql";
51 environment.etc."fail2ban/action.d/nftables-common.local".text = ''
55 environment.etc."fail2ban/filter.d/postgresql.local".text = ''
59 _daemon = postgresql-start
61 journalmatch = _SYSTEMD_UNIT=postgresql.service + _COMM=postgres
62 prefregex = ^<F-MLFID>%(__prefix_line)s</F-MLFID><F-CONTENT>.+</F-CONTENT>$
63 failregex = ^<HOST>\s+FATAL:\s*no pg_hba.conf entry for host.+$
64 ^<HOST>\s+FATAL:\s*no PostgreSQL user name specified in startup packet.+$
65 ^<HOST>\s+FATAL:\s*password authentication failed for user.+$
66 ^<HOST>\s+FATAL:\s*unsupported frontend protocol.+$
68 #ignoreregex = duration: