1 { pkgs, lib, config, ... }:
3 hardware.cpu.amd.updateMicrocode = true;
5 powerManagement.cpuFreqGovernor = lib.mkDefault "ondemand";
10 "vm.vfs_cache_pressure" = 50;
21 "/dev/disk/by-id/ata-Samsung_SSD_840_EVO_250GB_S1DBNSAF340110R"
25 { devices = [ "${disk_id}" ];
26 path = "/boot${bootnum}";
33 canTouchEfiVariables = true;
34 efiSysMountPoint = "/boot/efi";
35 efiInstallAsRemovable = false;
41 availableKernelModules = [
48 # Made the AES modules available at initrd,
49 # to speedup the deciphering of the root.
57 boot.kernelModules = [ ];
58 boot.extraModulePackages = [ ];
62 "console=ttyS0,115200n8"
63 "zfs.zfs_arc_max=262144000" # 250Mo
67 { device = "/dev/disk/by-uuid/dc3c5387-17d2-43b3-bfa2-bf73afacca07";
71 fileSystems."/boot/efi" =
72 { device = "/dev/disk/by-uuid/62E6-E65F";
77 [ { device = "/dev/disk/by-partuuid/6b1eaa35-776b-4e60-b21e-7bcee535dd8b";
80 cipher = "aes-xts-plain64";
81 source = "/dev/urandom";
87 systemPackages = with pkgs; [