]> Git — Sourcephile - sourcephile-nix.git/blob - hosts/mermet/system.nix
losurdo: nix-serve: enable over wireguard
[sourcephile-nix.git] / hosts / mermet / system.nix
1 { pkgs, lib, config, inputs, hostName, ... }:
2 let inherit (config) networking; in
3 {
4 # This value determines the NixOS release with which your system is to be
5 # compatible, in order to avoid breaking some software such as database servers.
6 # You should change this only after NixOS release notes say you should.
7 system.stateVersion = "19.09"; # Did you read the comment?
8
9 services.unbound.enable = true;
10
11 nix.gc.dates = "daily";
12 nix.gc.options = "--delete-older-than 2d";
13 nix.binaryCaches = [ "http://nix-extracache.losurdo.wg" ];
14 nix.binaryCachePublicKeys = [ (builtins.readFile (inputs.secrets + "/hosts/losurdo/nix/binary-cache-key/1.pub")) ];
15
16 environment.systemPackages = with pkgs; [
17 cryptsetup
18 direnv
19 file
20 fio
21 gdb
22 git
23 gptfdisk
24 #hey
25 home-manager
26 lm_sensors
27 rsync
28 smartctl-tbw
29 socat
30 thttpd
31 #iptables-nftables-compat
32 ];
33 }