]> Git — Sourcephile - sourcephile-nix.git/blob - machines/losurdo/fileSystems.nix
udev: add rules for MTP
[sourcephile-nix.git] / machines / losurdo / fileSystems.nix
1 { pkgs, lib, config, machineName, ... }:
2 {
3 imports = [
4 ../../nixos/profiles/systems/zfs.nix
5 ];
6
7 fileSystems."/" =
8 { device = "${machineName}/root";
9 fsType = "zfs";
10 };
11 boot.zfs.requestEncryptionCredentials = [ machineName ];
12
13 fileSystems."/nix" =
14 { device = "${machineName}/nix";
15 fsType = "zfs";
16 };
17
18 fileSystems."/var" =
19 { device = "${machineName}/var";
20 fsType = "zfs";
21 };
22
23 fileSystems."/var/cache" =
24 { device = "${machineName}/var/cache";
25 fsType = "zfs";
26 };
27
28 fileSystems."/var/log" =
29 { device = "${machineName}/var/log";
30 fsType = "zfs";
31 };
32
33 fileSystems."/var/lib/nginx" =
34 { device = "${machineName}/var/www";
35 fsType = "zfs";
36 };
37
38 fileSystems."/var/lib/postgresql" =
39 { device = "${machineName}/var/postgresql";
40 fsType = "zfs"; # with sync=always,
41 # though loading OpenConcerto's initial SQL
42 # takes 1m40s instead of 40s :\
43 };
44
45 fileSystems."/var/lib/transmission" =
46 { device = "${machineName}/var/torrents";
47 fsType = "zfs";
48 };
49
50 fileSystems."/var/tmp" =
51 { device = "${machineName}/var/tmp";
52 fsType = "zfs";
53 };
54
55 fileSystems."/mnt/key" =
56 { device = "/dev/disk/by-label/key";
57 fsType = "vfat";
58 options = [ "auto" "nofail" "uid=1000" "gid=users" "umask=111" "dmask=007" "utf8=yes" ];
59 };
60
61 # Allow members of the "adbusers" group to mount Android devices via MTP
62 services.udev.packages = [ pkgs.android-udev-rules ];
63 environment.systemPackages = [
64 pkgs.jmtpfs
65 ];
66
67 }