]> Git — Sourcephile - sourcephile-nix.git/blob - servers/mermet.nix
mermet: add openldap
[sourcephile-nix.git] / servers / mermet.nix
1 # This is the root configuration of the target machine.
2 # Usable by nixos-install and used by nixops.
3 # It is NOT copied nor usable on the target machine,
4 # only the resulting closure is copied to the target machine.
5 {pkgs, lib, config, options, nodes, resources, ...}:
6 let
7 inherit (builtins.extraBuiltins) pass;
8 in
9 {
10 # This value determines the NixOS release with which your system is to be
11 # compatible, in order to avoid breaking some software such as database servers.
12 # You should change this only after NixOS release notes say you should.
13 system.stateVersion = "19.09"; # Did you read the comment?
14
15 nixpkgs.overlays = import ../overlays.nix;
16
17 imports =
18 [ ../nixos/defaults.nix
19 mermet/apu2e4.nix
20 mermet/zfs.nix
21 mermet/lesptts.nix
22 mermet/shorewall.nix
23 mermet/unbound.nix
24 mermet/nsd.nix
25 mermet/openldap.nix
26 #mermet/rspamd.nix
27 #mermet/dovecot2.nix
28 ];
29
30 networking = rec {
31 hostName = "mermet";
32 domainBase = "sourcephile";
33 domain = "${domainBase}.fr";
34 };
35
36 users = {
37 mutableUsers = false;
38 users = {
39 root = rec {
40 initialPassword = password;
41 password = pass "servers/mermet/login/root";
42 openssh.authorizedKeys.keys = [
43 (pass "members/julm/ssh.pub")
44 ];
45 };
46 };
47 groups = {
48 };
49 };
50
51 environment = {
52 systemPackages = with pkgs; [
53 cryptsetup
54 fio
55 git
56 gptfdisk
57 lm_sensors
58 smartctl-tbw
59 socat
60 ];
61 };
62 }