]> Git — Sourcephile - sourcephile-nix.git/blob - servers/mermet/nsd/sourcephile.nix
mermet: add openldap
[sourcephile-nix.git] / servers / mermet / nsd / sourcephile.nix
1 {pkgs, lib, config, ...}:
2 with builtins;
3 let inherit (builtins.extraBuiltins) pass git;
4 inherit (pkgs.lib) unlinesAttrs;
5 inherit (config) networking;
6 inherit (config.services) nsd rspamd;
7 # Use the Git commit time of the ${zone}.nix file to set the serial number.
8 # WARNING: the ${zone}.nix must be committed into Git for this to work.
9 serial = zone: toString (git ./. [ "log" "-1" "--format=%ct" "--" (zone + ".nix") ]);
10 /*
11 serial = file: lib.removeSuffix "\n" (readFile
12 (pkgs.runCommand "zone-serial"
13 { buildInputs = [ pkgs.git ];
14 buildDepends = [ (toPath ./. + file) ];
15 preferLocalBuild = true;
16 allowSubstitutes = false;
17 } ''
18 cd ${toPath ./.}
19 ${pkgs.git}/bin/git log -1 --format="%ct" -- ${file} >$out
20 ''));
21 */
22 # FIXME: make dedicated config options
23 ipv4 = (elemAt networking.interfaces.enp1s0.ipv4.addresses 0).address;
24 ipv6 = (elemAt networking.interfaces.enp1s0.ipv6.addresses 0).address;
25 sourcephileZone = domain: ''
26 ; A (DNS -> IPv4)
27 @ A ${ipv4}
28 autoconfig A ${ipv4}
29 code A ${ipv4}
30 git A ${ipv4}
31 imap A ${ipv4}
32 mail A ${ipv4}
33 ns A ${ipv4}
34 pop A ${ipv4}
35 smtp A ${ipv4}
36 submission A ${ipv4}
37 www A ${ipv4}
38
39 ; SPF (Sender Policy Framework)
40 @ 3600 IN SPF "v=spf1 mx ip4:${ipv4} -all"
41 @ 3600 IN TXT "v=spf1 mx ip4:${ipv4} -all"
42
43 ; MX (Mail eXchange)
44 @ 180 MX 5 mail
45
46 ; SRV (SeRVice)
47 _git._tcp.git 18000 IN SRV 0 0 9418 git
48
49 ; TXT (TeXT)
50 ''
51 + lib.optionalString rspamd.dkim.enable
52 (unlinesAttrs
53 (selector: sel: sel.dns)
54 rspamd.dkim.domains."${domain}".selectors)
55 ;
56 in
57 {
58 services.nsd = {
59 zones = {
60 # NOTE: cannot use networking.domain as attr key: infinite recursion.
61 "sourcephile.fr" = {
62 data = ''
63 $ORIGIN ${networking.domainBase}.fr.
64 $TTL 86400
65
66 ; SOA (Start Of Authority)
67 @ SOA ns admin (
68 ${serial networking.domainBase} ; Serial number
69 1d ; Refresh
70 15m ; Retry
71 2592000 ; Expire
72 1d ; TTL (Time To Live) minimum
73 )
74
75 ; NS (Name Server)
76 @ NS ns
77 ;@ NS ns6.gandi.net.
78 ''
79 + sourcephileZone "${networking.domainBase}.fr";
80 };
81 };
82 };
83 }