1 { pkgs, lib, config, inputs, hostName, ... }:
2 let inherit (config) networking; in
4 # This value determines the NixOS release with which your system is to be
5 # compatible, in order to avoid breaking some software such as database servers.
6 # You should change this only after NixOS release notes say you should.
7 system.stateVersion = "19.09"; # Did you read the comment?
9 services.unbound.enable = true;
11 nix.gc.dates = "daily";
12 nix.gc.options = "--delete-older-than 2d";
13 nix.binaryCaches = [ "https://nix-extracache.${networking.domain}" ];
14 nix.binaryCachePublicKeys = [ (builtins.readFile (inputs.secrets + "/hosts/losurdo/nix/binary-cache-key/1.pub")) ];
16 environment.systemPackages = with pkgs; [
31 #iptables-nftables-compat