1 # Run with : nix run -f tests.nix
2 # Debug with : nix -L run -f tests.nix driver -c nixos-test-driver
3 { system ? builtins.currentSystem,
5 overlays ? nixpkgs/overlays.nix,
6 pkgs ? import <nixpkgs> { inherit system config overlays; },
11 (import (pkgs.path + /nixos/lib/testing-python.nix)) {
13 extraConfigurations = [
15 # Propagate pkgs and its overlays to the VM,
16 # instead of reloading nixpkgs.
17 config.nixpkgs.pkgs = lib.mkDefault pkgs;
18 config.documentation.enable = false;
26 mermet = {pkgs, ...}@attrs: {};
34 mermet.wait_for_unit("multi-user.target")
37 "mount -t tmpfs none /tmp/test",
38 "touch /tmp/test/hello",
39 "test -f /tmp/test/hello",