]> Git — Sourcephile - sourcephile-nix.git/blob - servers/mermet/system.nix
nix: add admin tools and setup shorewall
[sourcephile-nix.git] / servers / mermet / system.nix
1 { config, lib, pkgs, options, ... }:
2 let inherit (builtins.extraBuiltins) pass;
3 in
4 {
5 imports =
6 [ ./system/zfs.nix
7 ./system/shorewall.nix
8 ];
9
10 # This value determines the NixOS release with which your system is to be
11 # compatible, in order to avoid breaking some software such as database
12 # servers. You should change this only after NixOS release notes say you should.
13 system.stateVersion = "19.09"; # Did you read the comment?
14
15 # Clean /tmp automatically on boot.
16 boot.cleanTmpDir = true;
17
18 networking = {
19 hostName = "mermet";
20 domain = "sourcephile.fr";
21 };
22
23 users = {
24 mutableUsers = false;
25 users = {
26 root = rec {
27 initialPassword = password;
28 password = pass "servers/mermet/login/root";
29 openssh.authorizedKeys.keys = [
30 (pass "members/julm/ssh.pub")
31 ];
32 };
33 };
34 groups = {
35 };
36 };
37
38 environment = {
39 systemPackages = with pkgs; [
40 cryptsetup
41 fio
42 git
43 gptfdisk
44 lm_sensors
45 smartctl-tbw
46 ];
47 };
48 }