]> Git — Sourcephile - sourcephile-nix.git/blob - servers/mermet/staging.nix
x509: send the key once for root, not one per service
[sourcephile-nix.git] / servers / mermet / staging.nix
1 { pkgs, lib, config, options
2 # NixOps extra module inputs
3 , nodes, name, uuid, resources
4 , ... }:
5 let inherit (config) networking; in
6 {
7 imports =
8 [ ./keys.nix
9 staging/shorewall.nix
10 ];
11 config = {
12 services.nsd.interfaces = [ networking.privateIPv4 ];
13 nix.maxJobs = 2;
14 deployment = /*lib.mkIf (builtins.hasAttr "mermet" nodes)*/ {
15 targetEnv = "virtualbox";
16 virtualbox.headless = true;
17 virtualbox.memorySize = 1024;
18 virtualbox.vcpu = 2;
19 virtualbox.disks.disk1.baseImage = ../../.cache/nixops/virtualbox/nixops.vmdk;
20 # NOTE: resize not yet supported.
21 #virtualbox.disks.disk1.size = 6024;
22 #storeKeysOnMachine = true;
23 };
24 };
25 }