]> Git — Sourcephile - sourcephile-nix.git/blob - machines/losurdo/networking/nftables.nix
traceroute: enable for julm and root
[sourcephile-nix.git] / machines / losurdo / networking / nftables.nix
1 { pkgs, lib, config, machines, ... }:
2 let
3 inherit (builtins) hasAttr readFile;
4 inherit (pkgs.lib) unlinesAttrs;
5 inherit (config) networking;
6 inherit (config.users) users groups;
7 in
8 {
9 networking.firewall.enable = false;
10 security.lockKernelModules = false;
11 systemd.services.disable-kernel-module-loading.after = [ "nftables.service" ];
12 systemd.services.nftables.serviceConfig.TimeoutStartSec = "20";
13 networking.nftables = {
14 enable = true;
15 ruleset = lib.mkBefore ''
16 table inet filter {
17 set lograte4 { type ipv4_addr; size 65535; flags dynamic; }
18 set lograte6 { type ipv6_addr; size 65535; flags dynamic; }
19 chain block {
20 add @lograte4 { ip saddr limit rate 1/minute } log level warn prefix "block: "
21 add @lograte6 { ip6 saddr limit rate 1/minute } log level warn prefix "block: "
22 counter drop
23 }
24 chain ping-flood {
25 add @lograte4 { ip saddr limit rate 1/minute } log level warn prefix "ping-flood: "
26 add @lograte6 { ip6 saddr limit rate 1/minute } log level warn prefix "ping-flood: "
27 counter drop
28 }
29 chain smurf {
30 add @lograte4 { ip saddr limit rate 1/minute } log level warn prefix "smurf: "
31 add @lograte6 { ip6 saddr limit rate 1/minute } log level warn prefix "smurf: "
32 counter drop
33 }
34 chain bogus-tcp {
35 add @lograte4 { ip saddr limit rate 1/minute } log level warn prefix "bogus-tcp: "
36 add @lograte6 { ip6 saddr limit rate 1/minute } log level warn prefix "bogus-tcp: "
37 counter drop
38 }
39 chain syn-flood {
40 add @lograte4 { ip saddr limit rate 1/minute } log level warn prefix "syn-flood: "
41 add @lograte6 { ip6 saddr limit rate 1/minute } log level warn prefix "syn-flood: "
42 counter drop
43 }
44 chain check-tcp {
45 tcp flags syn tcp option maxseg size != 536-65535 counter goto bogus-tcp
46 tcp flags & (ack|fin) == fin counter goto bogus-tcp
47 tcp flags & (ack|psh) == psh counter goto bogus-tcp
48 tcp flags & (ack|urg) == urg counter goto bogus-tcp
49 tcp flags & (fin|ack) == fin counter goto bogus-tcp
50 tcp flags & (fin|rst) == (fin|rst) counter goto bogus-tcp
51 tcp flags & (fin|psh|ack) == (fin|psh) counter goto bogus-tcp
52 tcp flags & (syn|fin) == (syn|fin) counter goto bogus-tcp comment "SYN-FIN scan"
53 tcp flags & (syn|rst) == (syn|rst) counter goto bogus-tcp comment "SYN-RST scan"
54 tcp flags == (fin|syn|rst|psh|ack|urg) counter goto bogus-tcp comment "XMAS scan"
55 tcp flags == 0x0 counter goto bogus-tcp comment "NULL scan"
56 tcp flags == (fin|urg|psh) counter goto bogus-tcp
57 tcp flags == (fin|urg|psh|syn) counter goto bogus-tcp comment "NMAP-ID"
58 tcp flags == (fin|urg|syn|rst|ack) counter goto bogus-tcp
59
60 ct state new tcp flags != syn counter goto bogus-tcp
61 tcp sport 0 tcp flags & (fin|syn|rst|ack) == syn counter goto bogus-tcp
62 tcp flags & (fin|syn|rst|ack) == syn counter limit rate over 30/second burst 60 packets goto syn-flood
63 }
64 chain net2fw {
65 #udp dport mdns ip6 daddr ff02::fb counter accept comment "Accept mDNS"
66 #udp dport mdns ip daddr 224.0.0.251 counter accept comment "Accept mDNS"
67 #jump non-internet
68
69 #ct state new add @connlimit { ip saddr ct count over 20 } counter tcp reject with tcp reset
70
71 # Some .nix append rules here with: add rule inet filter net2fw ...
72 }
73 chain fw2net {
74 tcp dport { 80, 443 } counter accept comment "HTTP"
75 udp dport 123 skuid ${users.systemd-timesync.name} counter accept comment "NTP"
76 tcp dport 9418 counter accept comment "Git"
77
78 # Some .nix append rules here with: add rule inet filter fw2net ...
79 }
80 chain intra2fw {
81 # Some .nix append rules here with: add rule inet filter intra2fw ...
82 }
83 chain fw2intra {
84 # Some .nix append rules here with: add rule inet filter fw2intra ...
85 }
86 chain fwd-intra {
87 # Some .nix append rules here with: add rule inet filter fwd-intra ...
88 }
89 chain accept-icmpv6 {
90 # Traffic That Must Not Be Dropped
91 # https://tools.ietf.org/html/rfc4890#section-4.4.1
92 icmpv6 type destination-unreachable counter accept
93 icmpv6 type packet-too-big counter accept
94 icmpv6 type time-exceeded counter accept
95 icmpv6 type parameter-problem counter accept
96
97 # Address Configuration and Router Selection messages
98 # (must be received with hop limit = 255)
99 icmpv6 type nd-router-solicit ip6 hoplimit 255 counter accept
100 ip6 nexthdr ipv6-icmp icmpv6 type nd-router-advert ip6 hoplimit 255 counter accept
101 icmpv6 type nd-neighbor-solicit ip6 hoplimit 255 counter accept
102 icmpv6 type nd-neighbor-advert ip6 hoplimit 255 counter accept
103 icmpv6 type nd-redirect ip6 hoplimit 255 log level warn prefix "icmpv6: nd-redirect: " counter drop
104 icmpv6 type ind-neighbor-solicit ip6 hoplimit 255 counter accept
105 icmpv6 type ind-neighbor-advert ip6 hoplimit 255 counter accept
106
107 # Link-local multicast receiver notification messages
108 # (must have link-local source address)
109 icmpv6 type mld-listener-query ip6 saddr fe80::/10 counter accept
110 icmpv6 type mld-listener-report ip6 saddr fe80::/10 counter accept
111 icmpv6 type mld-listener-done ip6 saddr fe80::/10 counter accept
112 # https://tools.ietf.org/html/rfc3810 Multicast Listener Discovery Version 2 (MLDv2) for IPv6
113 icmpv6 type mld2-listener-report ip6 saddr fe80::/10 counter accept
114
115 # SEND Certificate Path notification messages
116 # (must be received with hop limit = 255)
117 icmpv6 type 148 ip6 hoplimit 255 counter accept comment "certificate-path-solicitation"
118 icmpv6 type 149 ip6 hoplimit 255 counter accept comment "certificate-path-advertisement"
119
120 # Multicast Router Discovery messages
121 # (must have link-local source address and hop limit = 1)
122 icmpv6 type 151 ip6 saddr fe80::/10 ip6 hoplimit 1 counter accept comment "multicast-router-advertisement"
123 icmpv6 type 152 ip6 saddr fe80::/10 ip6 hoplimit 1 counter accept comment "multicast-router-solicitation"
124 icmpv6 type 153 ip6 saddr fe80::/10 ip6 hoplimit 1 counter accept comment "multicast-router-termination"
125 }
126
127 chain input {
128 type filter hook input priority 0
129 policy drop
130
131 iifname lo accept
132
133 jump check-tcp
134
135 ct state { established, related } accept
136
137 # Connectivity checking messages
138 # (multicast) ping
139 ip protocol icmp icmp type echo-reply counter accept
140
141 ${lib.optionalString networking.enableIPv6 ''
142 # drop packets with rh0 headers
143 rt type 0 jump block
144 rt type 0 jump block
145 rt type 0 jump block
146
147 # (multicast) ping
148 ip6 nexthdr ipv6-icmp icmpv6 type echo-reply counter accept
149
150 #ip6 daddr fe80::/64 udp dport 546 counter accept comment "DHCPv6"
151 ''}
152
153 ct state invalid counter drop
154
155 ip protocol icmp icmp type destination-unreachable counter accept
156 ip protocol icmp icmp type time-exceeded counter accept
157 ip protocol icmp icmp type parameter-problem counter accept
158 ip protocol icmp icmp type echo-request limit rate over 10/second burst 20 packets goto ping-flood
159 ip protocol icmp icmp type echo-request counter accept
160 # echo-reply is handled before invalid packets to allow multicast ping
161 # which do not have an associated connection.
162
163 #ip daddr 224.0.0.251 udp dport 5353 counter accept comment "mDNS"
164 #ip daddr 239.255.255.250 udp dport 1900 counter accept comment "UPnP"
165 #ip saddr 0.0.0.0/32 counter accept comment "DHCP"
166 #ip udp sport 67 udp dport 68 counter accept comment "DHCP"
167
168 ${lib.optionalString networking.enableIPv6 ''
169 ip6 nexthdr ipv6-icmp jump accept-icmpv6
170
171 # Connectivity checking messages
172 icmpv6 type echo-request counter accept
173 # echo-reply is handled before invalid because of multicast
174
175 ip6 nexthdr ipv6-icmp log level err prefix "net2fw: icmpv6: catch all: " counter accept
176
177 ip6 daddr ff02::fb udp dport 5353 counter accept comment "mDNS"
178 ip6 daddr ff02::f udp dport 1900 counter accept comment "UPnP"
179 ''}
180
181 ip saddr 224.0.0.0/4 counter goto smurf
182 fib saddr type broadcast counter goto smurf
183
184 # admin services
185 tcp dport 22 counter accept comment "SSH"
186 udp dport 60000-61000 counter accept comment "Mosh"
187
188 # Some .nix append gotos here with: add rule inet filter input iffname ... goto ...
189 }
190 chain forward {
191 type filter hook forward priority 0
192 policy drop
193
194 ip protocol icmp icmp type destination-unreachable counter accept
195 ip protocol icmp icmp type time-exceeded counter accept
196 ip protocol icmp icmp type parameter-problem counter accept
197 ip protocol icmp icmp type echo-request counter accept
198
199 ${lib.optionalString networking.enableIPv6 ''
200 # Traffic That Must Not Be Dropped
201 # https://tools.ietf.org/html/rfc4890#section-4.3.1
202 ip6 nexthdr ipv6-icmp icmpv6 type destination-unreachable counter accept
203 ip6 nexthdr ipv6-icmp icmpv6 type packet-too-big counter accept
204 ip6 nexthdr ipv6-icmp icmpv6 type time-exceeded counter accept
205 ip6 nexthdr ipv6-icmp icmpv6 type parameter-problem counter accept
206
207 # Connectivity checking messages
208 ip6 nexthdr ipv6-icmp icmpv6 type echo-request counter accept
209 ip6 nexthdr ipv6-icmp icmpv6 type echo-reply counter accept
210
211 # Traffic That Normally Should Not Be Dropped
212 # https://tools.ietf.org/html/rfc4890#section-4.3.2
213 ip6 nexthdr ipv6-icmp icmpv6 type 144 counter accept comment "home-agent-address-discovery-request"
214 ip6 nexthdr ipv6-icmp icmpv6 type 145 counter accept comment "home-agent-address-discovery-reply"
215 ip6 nexthdr ipv6-icmp icmpv6 type 146 counter accept comment "mobile-prefix-solicitation"
216 ip6 nexthdr ipv6-icmp icmpv6 type 147 counter accept comment "mobile-prefix-advertisement"
217 ''}
218 }
219 chain output {
220 type filter hook output priority 0
221 policy drop
222
223 oifname lo accept
224
225 ct state { related, established } accept
226
227 ip protocol icmp counter accept
228 ip daddr 224.0.0.0/4 udp dport 1900 counter accept comment "UPnP"
229 meta skuid 0 udp dport 33434-33523 counter accept comment "traceroute"
230
231 ${lib.optionalString networking.enableIPv6 ''
232 ip6 nexthdr ipv6-icmp jump accept-icmpv6
233
234 # Connectivity checking messages
235 ip6 nexthdr ipv6-icmp icmpv6 type echo-request counter accept
236 ip6 nexthdr ipv6-icmp icmpv6 type echo-reply counter accept
237 ip6 nexthdr ipv6-icmp log level err prefix "fw2net: icmpv6: catch all: " counter accept
238
239 ip6 daddr ff02::1:2/64 udp dport 547 counter accept comment "DHCPv6"
240 ''}
241
242 ct state invalid log level warn prefix "fw2net: invalid: " counter drop
243
244 tcp dport 22 counter accept comment "SSH"
245
246 # Some .nix append gotos here with: add rule inet filter output oifname ... goto ...
247 }
248 }
249 '';
250 };
251 }