]> Git — Sourcephile - sourcephile-nix.git/blob - machines/losurdo/system.nix
nix: simplify the sending root's OpenPGP key
[sourcephile-nix.git] / machines / losurdo / system.nix
1 { pkgs, lib, config, ... }:
2 let
3 inherit (config) networking;
4 inherit (config.security) pass;
5 in
6 {
7 # This value determines the NixOS release with which your system is to be
8 # compatible, in order to avoid breaking some software such as database servers.
9 # You should change this only after NixOS release notes say you should.
10 system.stateVersion = "19.09"; # Did you read the comment?
11
12 # Avoid the use of systemd-run --user --scope tmux
13 # and let mosh work smoothly.
14 services.logind.killUserProcesses = false;
15
16 nix.gc.dates = "daily";
17 nix.gc.options = "--delete-older-than 7d";
18
19 services.unbound.enable = true;
20
21 environment.systemPackages = with pkgs; [
22 cryptsetup
23 direnv
24 file
25 fio
26 gdb
27 git
28 gptfdisk
29 #hey
30 home-manager
31 lm_sensors
32 rsync
33 smartctl-tbw
34 socat
35 sanoid
36 #iptables-nftables-compat
37 gnupg
38 miniupnpc
39 ];
40 }