]> Git — Sourcephile - sourcephile-nix.git/blob - hosts/losurdo/security.nix
nix: update nixpkgs
[sourcephile-nix.git] / hosts / losurdo / security.nix
1 { inputs, pkgs, lib, config, ... }:
2 {
3 security.lockKernelModules = false;
4 security.gnupg.agent = {
5 keyring."9AA84E6F6D71F9163C46BF396B141A0806219077" = {
6 passwordGpg = "gnupg/root.gpg";
7 };
8 };
9 services.openssh.extraConfig = ''
10 # This is for removing remote gpg-agent's socket
11 StreamLocalBindUnlink yes
12 '';
13 }