]> Git — Sourcephile - sourcephile-nix.git/blob - hosts/mermet/security.nix
nix: update nixpkgs
[sourcephile-nix.git] / hosts / mermet / security.nix
1 { inputs, pkgs, lib, config, ... }:
2 {
3 security.gnupg.agent = {
4 keyring."89F52A879E0019A966503AFFDE72EEA84CDFA3A7" = {
5 passwordGpg = "gnupg/root.gpg";
6 };
7 };
8 services.openssh.extraConfig = ''
9 # This is for removing remote gpg-agent's socket
10 StreamLocalBindUnlink yes
11 '';
12 }