]> Git — Sourcephile - sourcephile-nix.git/blob - servers/mermet/dovecot.nix
dovecot: fix julm's sieve by setting home through mailHomeDirectory
[sourcephile-nix.git] / servers / mermet / dovecot.nix
1 { pkgs, lib, config, system, ... }:
2 let
3 inherit (builtins) toString toFile readFile;
4 inherit (builtins.extraBuiltins) pass;
5 inherit (lib) types;
6 inherit (pkgs.lib) loadFile unlines unlinesAttrs unlinesValues unwords;
7 inherit (config) networking;
8 inherit (config.services) dovecot2 postfix openldap;
9
10 # NOTE: nixpkgs' dovecot2.stateDir is currently not exported
11 stateDir = "/var/lib/dovecot";
12
13 sieve_pipe_bin_dir = pkgs.buildEnv {
14 name = "sieve_pipe_bin_dir";
15 pathsToLink = [ "/bin" ];
16 paths = [
17 learn-spam
18 learn-ham
19 ];
20 };
21 learn-spam = pkgs.writeShellScriptBin "learn-spam.sh" ''
22 exec ${pkgs.rspamd}/bin/rspamc -h /run/rspamd/learner.sock learn_spam
23 '';
24 learn-ham = pkgs.writeShellScriptBin "learn-ham.sh" ''
25 exec ${pkgs.rspamd}/bin/rspamc -h /run/rspamd/learner.sock learn_ham
26 '';
27
28 dovecot-virtual = pkgs.buildEnv {
29 name = "dovecot-virtual";
30 pathsToLink = [ "/" ];
31 paths = [
32 dovecot-virtual-all
33 dovecot-virtual-recents
34 ];
35 };
36 dovecot-virtual-all = pkgs.writeTextFile {
37 name = "dovecot-virtual-all";
38 destination = "/All/dovecot-virtual";
39 text = ''
40 *
41 all
42 '';
43 };
44 dovecot-virtual-recents = pkgs.writeTextFile {
45 name = "dovecot-virtual-recents";
46 destination = "/Recents/dovecot-virtual";
47 text = ''
48 *
49 all younger 172800
50 '';
51 };
52 dovecot-virtual-pop3 = pkgs.writeTextFile {
53 name = "dovecot-virtual-pop3";
54 destination = "/pop3/INBOX/dovecot-virtual";
55 text = ''
56 All
57 All+*
58 all
59 '';
60 };
61 in
62 {
63 imports = [
64 dovecot/sourcephile.fr.nix
65 dovecot/autogeree.net.nix
66 ];
67 users.groups.acme.members = [ dovecot2.user ];
68 systemd.services.dovecot2 = {
69 after = [
70 "postfix.service"
71 "openldap.service"
72 ];
73 /*
74 preStart = ''
75 # SEE: http://wiki2.dovecot.org/SharedMailboxes/Permissions
76 install -D -d -m 0771 \
77 -o "${dovecot2.user}" \
78 -g "${dovecot2.group}" \
79 ${stateDir}/mail
80 '';
81 */
82 };
83 #users.users."${dovecot2.mailUser}".isSystemUser = true; # Fix nixpkgs
84 services.dovecot2 = {
85 enable = true;
86 modules = [
87 pkgs.dovecot_pigeonhole
88 pkgs.dovecot_fts_xapian
89 ];
90 enablePAM = false;
91 enableImap = true;
92 enableLmtp = true;
93 enablePop3 = false;
94 protocols = [ "sieve" ];
95 # If needed, may be overrided by userdb_mail= in passdb, or mail= in userdb
96 # Here INDEX and CONTROL are separated,
97 # it's not useful since there is no quota at the filesystem level
98 # it's just to let this possibility later on.
99 mailLocation = "sdbox:${stateDir}/home/%d/%n/mail:UTF-8:CONTROL=${stateDir}/control/%d/%n:INDEX=${stateDir}/index/%d/%n";
100 createMailUser = false;
101 mailUser = "";
102 mailGroup = "";
103 sslServerCert = null;
104 sieveScripts = {
105 global = dovecot/sieve/global;
106 };
107 extraConfig = ''
108 auth_verbose = no
109 auth_debug = no
110 mail_debug = no
111 verbose_ssl = no
112 log_timestamp = "%Y-%m-%d %H:%M:%S "
113
114 ssl = required
115 ssl_dh = <${../../../sec/openssl/dh.pem}
116 ssl_cipher_list = HIGH:!LOW:!SSLv2:!EXP:!aNULL
117 ssl_prefer_server_ciphers = yes
118 ssl_cert = </var/lib/acme/${networking.domain}/fullchain.pem
119 ssl_key = </var/lib/acme/${networking.domain}/key.pem
120 #ssl_ca = <''${caPath}
121 #ssl_verify_client_cert = yes
122
123 listen = *
124 mail_home = ${stateDir}/home/%d/%n
125 # Read multiple mails in parallel, improves performance
126 mail_prefetch_count = 20
127 # Default VSZ (virtual memory size) limit for service processes. This is mainly
128 # intended to catch and kill processes that leak memory before they eat up everything.
129 # Increased for fts_xapian.
130 default_vsz_limit = 1G
131
132 # DOC: https://doc.dovecot.org/configuration_manual/authentication/authentication_mechanisms/
133 # DOC: https://ldapwiki.com/wiki/DIGEST-MD5
134 # The misunderstanding is the notion "password sent over the network in plain-text" is not secure,
135 # when in fact, storing the password in the directory server using a Salted SHA-2 hash
136 # and transmitting the clear text password over a secure connection
137 # is more secure than having the directory server store the password in clear text
138 # or in a reversible encryption scheme.
139 # Therefore, SASL with DIGEST-MD5 (or CRAM-MD5) should be avoided.
140 # Use doveadm pw -s SSHA
141 # or doveadm pw -s PBKDF2 -r 10000
142 # or slappasswd -o module-load=pw-pbkdf2 -h "{PBKDF2-SHA256}"
143 auth_mechanisms = plain login
144 auth_username_format = %Ln
145 service auth {
146 user = ${dovecot2.user}
147 # auth_socket_path points to this userdb socket by default. It's typically
148 # used by dovecot-lda, doveadm, possibly imap process, etc.
149 # Users that have access to this socket are able to get a list
150 # of all usernames and get results of everyone's userdb lookups.
151 unix_listener auth-userdb {
152 user = ${dovecot2.user}
153 group = ${dovecot2.group}
154 mode = 0660
155 }
156 unix_listener /var/lib/postfix/queue/private/auth {
157 user = ${postfix.user}
158 group = ${postfix.group}
159 mode = 0660
160 }
161 }
162 service auth-worker {
163 user = ${dovecot2.user}
164 }
165 auth_cache_verify_password_with_worker = yes
166 # SEE: http://wiki2.dovecot.org/Quota/FS
167 # NOTE: postfix does not supply a client cert.
168 auth_ssl_require_client_cert = no
169 #auth_ssl_username_from_cert = yes
170 # NOTE: lowercase the username, help with LDAP?
171 auth_username_format = %Lu
172 # NOTE: sync with LDAP's data.
173 first_valid_uid = 1000
174 disable_plaintext_auth = yes
175
176 userdb {
177 driver = ldap
178 # A different path than passdb's args enables non-blocking LDAP requests
179 args = ${pkgs.symlinkJoin {name="ldap"; paths=[./dovecot];}}/ldap.conf
180 default_fields =
181 override_fields =
182 }
183
184 # No dirty syncs for maildir: locations which may be used directly by neomutt
185 maildir_very_dirty_syncs = no
186 namespace Inbox {
187 type = private
188 inbox = yes
189 hidden = no
190 list = yes
191 prefix =
192 separator = +
193 }
194 namespace Shared {
195 type = shared
196 #list = children
197 # NOTE: always listed in the LIST command.
198 list = yes
199 # NOTE: how to access the other users' mailboxes.
200 # NOTE: %var expands to the logged in user's variable, while
201 # %%var expands to the other users' variables.
202 # NOTE: INDEX and CONTROL are shared, INDEXPVT is not.
203 location = sdbox:${stateDir}/home/%%d/%%n/${stateDir}/mail:UTF-8:CONTROL=${stateDir}/control/%%d/%%n/shared:INDEX=${stateDir}/index/%%d/%%n/shared:INDEXPVT=${stateDir}/index/%d/%n/shared/%%n
204 prefix = Partages+%%n+
205 separator = +
206 subscriptions = yes
207 }
208 mail_plugins = $mail_plugins virtual
209 namespace Virtual {
210 prefix = Virtual+
211 separator = +
212 hidden = no
213 list = yes
214 subscriptions = no
215 location = virtual:${dovecot-virtual}:UTF-8:INDEX=${stateDir}/index/%d/%n/virtual
216 }
217
218 mail_plugins = $mail_plugins acl
219 plugin {
220 acl = vfile:/etc/dovecot/acl/global
221 acl_anyone = allow
222 # NOTE: to let users LIST mailboxes shared by other users,
223 # Dovecot needs a shared mailbox dictionary.
224 # FIXME: %d not working with userdb ldap
225 acl_shared_dict = file:${stateDir}/acl/%d/acl.db
226 }
227
228 mail_plugins = $mail_plugins fts fts_xapian
229 plugin {
230 # WARNING: doveadm fts rescan is buggy, it will delete the index:
231 # https://dovecot.org/pipermail/dovecot/2019-February/114709.html
232 # If need be, use rather: doveadm index -u "*@sourcephile.fr" -q '*'
233 plugin = fts fts_xapian
234 fts = xapian
235 fts_autoindex = yes
236 fts_autoindex_exclude = \Junk
237 fts_autoindex_exclude2 = \Trash
238 fts_enforced = yes
239 # 2 and 20 are the NGram values for header fields, which means the
240 # keywords created for fields (To, Cc, ...) are between is 2 and 20 chars long.
241 # Full words are also added by default.
242 fts_xapian = partial=2 full=20 attachments=1 verbose=0
243 fts_languages = en fr
244 #fts_dovecot_fs = posix:prefix=%h/fts/
245 }
246
247 mail_plugins = $mail_plugins quota
248 plugin {
249 quota = maildir:User quota
250 quota_rule = *:storage=256M
251 quota_rule2 = Trash:storage=+64M
252 quota_max_mail_size = 20M
253 #quota_exceeded_message = </path/to/quota_exceeded_message.txt
254 quota_warning = storage=95%% quota-warning 95 %u
255 quota_warning2 = storage=80%% quota-warning 80 %u
256 quota_warning3 = -storage=100%% quota-warning below %u
257 }
258
259 protocol lda {
260 hostname = ${networking.domain}
261 mail_plugins = $mail_plugins sieve
262 postmaster_address = postmaster+dovecot+lda@${networking.domain}
263 syslog_facility = mail
264 }
265 lda_mailbox_autocreate = yes
266 lda_mailbox_autosubscribe = yes
267
268 protocol lmtp {
269 mail_plugins = $mail_plugins sieve
270 postmaster_address = postmaster+dovecot+lmtp@${networking.domain}
271 }
272 service lmtp {
273 process_min_avail = ${toString config.nix.maxJobs}
274 unix_listener /var/lib/postfix/queue/private/dovecot-lmtp {
275 user = ${postfix.user}
276 group = ${postfix.group}
277 mode = 0600
278 }
279 }
280 plugin {
281 # Let extension.sieve do the handling of the detail
282 #lmtp_save_to_detail_mailbox = yes
283 recipient_delimiter = ${postfix.recipientDelimiter}
284 }
285
286 service imap {
287 # Most of the memory goes to mmap()ing files.
288 # You may need to increase this limit if you have huge mailboxes.
289 #vsz_limit =
290 process_limit = 1024
291 }
292 service imap-login {
293 #inet_listener imap {
294 # address = 127.0.0.1
295 # port = 143
296 # ssl = no
297 #}
298 inet_listener imaps {
299 port = 993
300 ssl = yes
301 }
302 }
303 # Store METADATA information within user's HOME directory
304 mail_attribute_dict = file:%h/dovecot-attributes
305 # If you have Dovecot v2.2.8+ you may get a significant performance improvement with fetch-headers:
306 imapc_features = $imapc_features fetch-headers
307 protocol imap {
308 #mail_max_userip_connections = 10
309 mail_plugins = $mail_plugins imap_acl imap_quota imap_sieve virtual
310 imap_metadata = yes
311
312 # DOC: https://wiki.dovecot.org/MailboxSettings
313 # Due to a bug in Dovecot v2.2.30+ if special-use flags are used,
314 # SPECIAL-USE needs to be added to post-login CAPABILITY response as RFC 6154 mandates.
315 imap_capability = +SPECIAL-USE
316
317 namespace Inbox {
318 mailbox "Archives" {
319 auto = subscribe
320 special_use = \Archive
321 }
322 mailbox "Drafts" {
323 auto = no
324 special_use = \Drafts
325 }
326 mailbox "Brouillons" {
327 auto = subscribe
328 special_use = \Drafts
329 }
330 mailbox "Junk" {
331 auto = no
332 #autoexpunge = 30d
333 special_use = \Junk
334 }
335 mailbox "Spams" {
336 auto = no
337 special_use = \Junk
338 }
339 mailbox "Spam" {
340 auto = no
341 special_use = \Junk
342 }
343 mailbox "Pourriels" {
344 auto = no
345 special_use = \Junk
346 }
347 mailbox "Pourriel" {
348 auto = no
349 special_use = \Junk
350 }
351 mailbox "Sent" {
352 auto = no
353 special_use = \Sent
354 }
355 mailbox "Sent Items" {
356 auto = no
357 special_use = \Sent
358 }
359 mailbox "Sent Messages" {
360 auto = no
361 special_use = \Sent
362 }
363 mailbox "Envoyés" {
364 auto = no
365 special_use = \Sent
366 }
367 mailbox "Trash" {
368 auto = no
369 special_use = \Trash
370 #autoexpunge = 30d
371 }
372 mailbox "Corbeille" {
373 auto = no
374 special_use = \Trash
375 }
376 }
377 namespace Virtual {
378 mailbox All {
379 auto = no
380 comment = All messages from all mailboxes
381 # This flag is confused with \Archives by K9-Mail
382 special_use = \All
383 }
384 mailbox Recents {
385 auto = no
386 comment = All messages from all mailboxes, arrived in the past 48h
387 }
388 }
389 }
390 plugin {
391 sieve_plugins = sieve_imapsieve sieve_extprograms
392 sieve_global_extensions = +vnd.dovecot.environment +vnd.dovecot.pipe
393 #sieve_extensions = +editheader
394 sieve = file:~/sieve;active=~/active.sieve
395 sieve_default = file:${stateDir}/sieve/global/default.sieve
396 sieve_default_name = main
397 sieve_pipe_bin_dir = ${sieve_pipe_bin_dir}/bin
398 sieve_max_script_size = 1M
399 sieve_quota_max_scripts = 0
400 sieve_quota_max_storage = 10M
401 #sieve_spamtest_max_value = 10
402 #sieve_spamtest_status_header = X-Spam-Score
403 #sieve_spamtest_status_type = strlen
404 #sieve_user_log = ~/sieve.log
405 # Enables support for user Sieve scripts in IMAP
406 #imapsieve_url = sieve://mail.${networking.domain}:4190
407
408 # When a flag changes, spam or ham according to the \Junk or \NonJunk flags
409 imapsieve_mailbox1_name = *
410 imapsieve_mailbox1_causes = FLAG
411 imapsieve_mailbox1_before = file:${stateDir}/sieve/global/spam-or-ham.sieve
412
413 # From elsewhere to Junk folder
414 imapsieve_mailbox2_name = Pourriel
415 imapsieve_mailbox2_causes = COPY APPEND
416 imapsieve_mailbox2_before = file:${stateDir}/sieve/global/report-spam.sieve
417
418 # From Junk folder to elsewhere
419 imapsieve_mailbox3_name = *
420 imapsieve_mailbox3_from = Pourriel
421 imapsieve_mailbox3_causes = COPY
422 imapsieve_mailbox3_before = file:${stateDir}/sieve/global/report-ham.sieve
423 }
424 protocol sieve {
425 # Maximum number of ManageSieve connections allowed for a user from each IP address.
426 # NOTE: The username is compared case-sensitively.
427 mail_max_userip_connections = 10
428
429 # To fool ManageSieve clients that are focused on CMU's timesieved you can specify
430 # the IMPLEMENTATION capability that the dovecot reports to clients.
431 # For example: 'Cyrus timesieved v2.2.13'
432 managesieve_implementation_string = Dovecot Pigeonhole
433
434 # The maximum number of compile errors that are returned to the client upon script
435 # upload or script verification.
436 managesieve_max_compile_errors = 5
437
438 #mail_max_userip_connections = 10
439 #managesieve_implementation_string = Dovecot Pigeonhole
440 managesieve_max_compile_errors = 5
441 #managesieve_max_line_length = 65536
442 #managesieve_notify_capability = mailto
443 #managesieve_sieve_capability = fileinto reject envelope encoded-character vacation subaddress comparator-i;ascii-numeric relational regex imap4flags copy include variables body enotify environment mailbox date ihave
444 }
445 service managesieve-login {
446 inet_listener sieve {
447 port = 4190
448 #ssl = yes
449 }
450
451 # Number of connections to handle before starting a new process. Typically
452 # the only useful values are 0 (unlimited) or 1. 1 is more secure, but 0
453 # is faster. <doc/wiki/LoginProcess.txt>
454 service_count = 1
455
456 # Number of processes to always keep waiting for more connections.
457 process_min_avail = 0
458
459 # If you set service_count=0, you probably need to grow this.
460 #vsz_limit = 64M
461 }
462
463 service quota-warning {
464 executable = script ${
465 pkgs.writeShellScript "quota-warning" ''
466 set -eu
467 PERCENT=$1
468 USER=$2
469 cat << EOF | ${pkgs.dovecot}/libexec/dovecot/dovecot-lda -d $USER -o
470 "plugin/quota=maildir:User quota:noenforcing"
471 From: postmaster@${networking.domain}
472 Subject: [WARNING] your mailbox is now $PERCENT% full.
473
474 Please remove some mails to make room for new ones.
475 EOF
476 ''
477 }
478 # use some unprivileged user for executing the quota warnings
479 user = ${dovecot2.user}
480 unix_listener quota-warning {
481 }
482 }
483
484 protocol pop3 {
485 mail_plugins = $mail_plugins virtual
486 #mail_max_userip_connections = 10
487 # Virtual namespace for the virtual INBOX.
488 # Use a global directory for dovecot-virtual files.
489 #namespace Inbox {
490 # hidden = yes
491 # list = no
492 # location = virtual:''${dovecot-virtual-pop3}/pop3:INDEX=${stateDir}/index/%d/%n/virtual/pop3:LAYOUT=fs
493 # prefix = pop3+
494 #}
495 pop3_client_workarounds =
496 pop3_fast_size_lookups = yes
497 pop3_lock_session = yes
498 pop3_no_flag_updates = yes
499 # Use GUIDs to avoid accidental POP3 UIDL changes instead of IMAP UIDs.
500 pop3_uidl_format = %g
501 }
502 service pop3 {
503 process_limit = 1024
504 }
505 service pop3-login {
506 inet_listener pop3s {
507 port = 995
508 ssl = yes
509 }
510 }
511 '';
512 };
513 }