1 # This is the root configuration of the target machine.
2 # Usable by nixos-install and used by nixops.
3 # It is NOT copied nor usable on the target machine,
4 # only the resulting closure is copied to the target machine.
5 { pkgs, lib, config, options, ... }@attrs:
7 inherit (builtins) getEnv hasAttr readFile;
8 inherit (builtins.extraBuiltins) pass pass-chomp;
11 # This value determines the NixOS release with which your system is to be
12 # compatible, in order to avoid breaking some software such as database servers.
13 # You should change this only after NixOS release notes say you should.
14 system.stateVersion = "19.09"; # Did you read the comment?
17 (./. + ("/" + getEnv "MERMET_DEPLOYMENT" + ".nix"))
19 ../../base/unbound.nix
30 ] ++ lib.optional (hasAttr "nodes" attrs)
31 (pkgs.nixops + "/share/nix/nixops/options.nix");
35 domainBase = "sourcephile";
36 domain = "${domainBase}.fr";
40 environment.etc."sudo.conf".text = ''
41 Debug sudo /var/log/sudo_debug.log all@debug
42 Debug sudoers.so /var/log/sudo_debug.log all@debug
46 systemd.coredump.enable = true;
49 enableDebugInfo = true;
50 systemPackages = with pkgs; [