1 { pkgs, lib, config, machines, ... }:
3 inherit (builtins) hasAttr readFile;
4 inherit (pkgs.lib) unlinesAttrs;
5 inherit (config) networking;
6 inherit (config.users) users groups;
9 networking.firewall.enable = false;
10 security.lockKernelModules = false;
11 systemd.services.disable-kernel-module-loading.after = [ "nftables.service" ];
12 systemd.services.nftables.serviceConfig.TimeoutStartSec = "20";
13 networking.nftables = {
15 ruleset = lib.mkBefore ''
17 set lograte4 { type ipv4_addr; size 65535; flags dynamic; }
18 set lograte6 { type ipv6_addr; size 65535; flags dynamic; }
20 add @lograte4 { ip saddr limit rate 1/minute } log level warn prefix "block: "
21 add @lograte6 { ip6 saddr limit rate 1/minute } log level warn prefix "block: "
25 add @lograte4 { ip saddr limit rate 1/minute } log level warn prefix "ping-flood: "
26 add @lograte6 { ip6 saddr limit rate 1/minute } log level warn prefix "ping-flood: "
30 add @lograte4 { ip saddr limit rate 1/minute } log level warn prefix "smurf: "
31 add @lograte6 { ip6 saddr limit rate 1/minute } log level warn prefix "smurf: "
35 add @lograte4 { ip saddr limit rate 1/minute } log level warn prefix "bogus-tcp: "
36 add @lograte6 { ip6 saddr limit rate 1/minute } log level warn prefix "bogus-tcp: "
40 add @lograte4 { ip saddr limit rate 1/minute } log level warn prefix "syn-flood: "
41 add @lograte6 { ip6 saddr limit rate 1/minute } log level warn prefix "syn-flood: "
45 tcp flags syn tcp option maxseg size != 536-65535 counter goto bogus-tcp
46 tcp flags & (ack|fin) == fin counter goto bogus-tcp
47 tcp flags & (ack|psh) == psh counter goto bogus-tcp
48 tcp flags & (ack|urg) == urg counter goto bogus-tcp
49 tcp flags & (fin|ack) == fin counter goto bogus-tcp
50 tcp flags & (fin|rst) == (fin|rst) counter goto bogus-tcp
51 tcp flags & (fin|psh|ack) == (fin|psh) counter goto bogus-tcp
52 tcp flags & (syn|fin) == (syn|fin) counter goto bogus-tcp comment "SYN-FIN scan"
53 tcp flags & (syn|rst) == (syn|rst) counter goto bogus-tcp comment "SYN-RST scan"
54 tcp flags == (fin|syn|rst|psh|ack|urg) counter goto bogus-tcp comment "XMAS scan"
55 tcp flags == 0x0 counter goto bogus-tcp comment "NULL scan"
56 tcp flags == (fin|urg|psh) counter goto bogus-tcp
57 tcp flags == (fin|urg|psh|syn) counter goto bogus-tcp comment "NMAP-ID"
58 tcp flags == (fin|urg|syn|rst|ack) counter goto bogus-tcp
60 ct state new tcp flags != syn counter goto bogus-tcp
61 tcp sport 0 tcp flags & (fin|syn|rst|ack) == syn counter goto bogus-tcp
62 tcp flags & (fin|syn|rst|ack) == syn counter limit rate over 30/second burst 60 packets goto syn-flood
65 #udp dport mdns ip6 daddr ff02::fb counter accept comment "Accept mDNS"
66 #udp dport mdns ip daddr 224.0.0.251 counter accept comment "Accept mDNS"
69 #ct state new add @connlimit { ip saddr ct count over 20 } counter tcp reject with tcp reset
71 # Some .nix append rules here with: add rule inet filter net2fw ...
74 tcp dport { 80, 443 } counter accept comment "HTTP"
75 udp dport 123 skuid ${users.systemd-timesync.name} counter accept comment "NTP"
76 tcp dport 9418 counter accept comment "Git"
78 # Some .nix append rules here with: add rule inet filter fw2net ...
81 # Some .nix append rules here with: add rule inet filter intra2fw ...
84 # Some .nix append rules here with: add rule inet filter fw2intra ...
87 # Some .nix append rules here with: add rule inet filter fwd-intra ...
90 # Some .nix append rules here with: add rule inet filter extra2fw ...
93 # Traffic That Must Not Be Dropped
94 # https://tools.ietf.org/html/rfc4890#section-4.4.1
95 icmpv6 type destination-unreachable counter accept
96 icmpv6 type packet-too-big counter accept
97 icmpv6 type time-exceeded counter accept
98 icmpv6 type parameter-problem counter accept
100 # Address Configuration and Router Selection messages
101 # (must be received with hop limit = 255)
102 icmpv6 type nd-router-solicit ip6 hoplimit 255 counter accept
103 ip6 nexthdr ipv6-icmp icmpv6 type nd-router-advert ip6 hoplimit 255 counter accept
104 icmpv6 type nd-neighbor-solicit ip6 hoplimit 255 counter accept
105 icmpv6 type nd-neighbor-advert ip6 hoplimit 255 counter accept
106 icmpv6 type nd-redirect ip6 hoplimit 255 log level warn prefix "icmpv6: nd-redirect: " counter drop
107 icmpv6 type ind-neighbor-solicit ip6 hoplimit 255 counter accept
108 icmpv6 type ind-neighbor-advert ip6 hoplimit 255 counter accept
110 # Link-local multicast receiver notification messages
111 # (must have link-local source address)
112 icmpv6 type mld-listener-query ip6 saddr fe80::/10 counter accept
113 icmpv6 type mld-listener-report ip6 saddr fe80::/10 counter accept
114 icmpv6 type mld-listener-done ip6 saddr fe80::/10 counter accept
115 # https://tools.ietf.org/html/rfc3810 Multicast Listener Discovery Version 2 (MLDv2) for IPv6
116 icmpv6 type mld2-listener-report ip6 saddr fe80::/10 counter accept
118 # SEND Certificate Path notification messages
119 # (must be received with hop limit = 255)
120 icmpv6 type 148 ip6 hoplimit 255 counter accept comment "certificate-path-solicitation"
121 icmpv6 type 149 ip6 hoplimit 255 counter accept comment "certificate-path-advertisement"
123 # Multicast Router Discovery messages
124 # (must have link-local source address and hop limit = 1)
125 icmpv6 type 151 ip6 saddr fe80::/10 ip6 hoplimit 1 counter accept comment "multicast-router-advertisement"
126 icmpv6 type 152 ip6 saddr fe80::/10 ip6 hoplimit 1 counter accept comment "multicast-router-solicitation"
127 icmpv6 type 153 ip6 saddr fe80::/10 ip6 hoplimit 1 counter accept comment "multicast-router-termination"
131 type filter hook input priority filter
138 ct state { established, related } accept
140 # Connectivity checking messages
142 ip protocol icmp icmp type echo-reply counter accept
144 ${lib.optionalString networking.enableIPv6 ''
145 # drop packets with rh0 headers
151 ip6 nexthdr ipv6-icmp icmpv6 type echo-reply counter accept
153 #ip6 daddr fe80::/64 udp dport 546 counter accept comment "DHCPv6"
156 ct state invalid counter drop
158 ip protocol icmp icmp type destination-unreachable counter accept
159 ip protocol icmp icmp type time-exceeded counter accept
160 ip protocol icmp icmp type parameter-problem counter accept
161 ip protocol icmp icmp type echo-request limit rate over 10/second burst 20 packets goto ping-flood
162 ip protocol icmp icmp type echo-request counter accept
163 # echo-reply is handled before invalid packets to allow multicast ping
164 # which do not have an associated connection.
166 #ip daddr 224.0.0.251 udp dport 5353 counter accept comment "mDNS"
167 #ip daddr 239.255.255.250 udp dport 1900 counter accept comment "UPnP"
168 #ip saddr 0.0.0.0/32 counter accept comment "DHCP"
169 #ip udp sport 67 udp dport 68 counter accept comment "DHCP"
171 ${lib.optionalString networking.enableIPv6 ''
172 ip6 nexthdr ipv6-icmp jump accept-icmpv6
174 # Connectivity checking messages
175 icmpv6 type echo-request counter accept
176 # echo-reply is handled before invalid because of multicast
178 ip6 nexthdr ipv6-icmp log level err prefix "net2fw: icmpv6: catch all: " counter reject
180 ip6 daddr ff02::fb udp dport 5353 counter accept comment "mDNS"
181 ip6 daddr ff02::f udp dport 1900 counter accept comment "UPnP"
184 ip saddr 224.0.0.0/4 counter goto smurf
185 fib saddr type broadcast counter goto smurf
188 tcp dport 22 counter accept comment "SSH"
189 udp dport 60000-61000 counter accept comment "Mosh"
191 # Some .nix append gotos here with: add rule inet filter input iffname ... goto ...
194 type filter hook forward priority filter
197 ct state { related, established } accept
199 ip protocol icmp icmp type destination-unreachable counter accept
200 ip protocol icmp icmp type time-exceeded counter accept
201 ip protocol icmp icmp type parameter-problem counter accept
202 ip protocol icmp icmp type echo-request counter accept
204 ${lib.optionalString networking.enableIPv6 ''
205 # Traffic That Must Not Be Dropped
206 # https://tools.ietf.org/html/rfc4890#section-4.3.1
207 ip6 nexthdr ipv6-icmp icmpv6 type destination-unreachable counter accept
208 ip6 nexthdr ipv6-icmp icmpv6 type packet-too-big counter accept
209 ip6 nexthdr ipv6-icmp icmpv6 type time-exceeded counter accept
210 ip6 nexthdr ipv6-icmp icmpv6 type parameter-problem counter accept
212 # Connectivity checking messages
213 ip6 nexthdr ipv6-icmp icmpv6 type echo-request counter accept
214 ip6 nexthdr ipv6-icmp icmpv6 type echo-reply counter accept
216 # Traffic That Normally Should Not Be Dropped
217 # https://tools.ietf.org/html/rfc4890#section-4.3.2
218 ip6 nexthdr ipv6-icmp icmpv6 type 144 counter accept comment "home-agent-address-discovery-request"
219 ip6 nexthdr ipv6-icmp icmpv6 type 145 counter accept comment "home-agent-address-discovery-reply"
220 ip6 nexthdr ipv6-icmp icmpv6 type 146 counter accept comment "mobile-prefix-solicitation"
221 ip6 nexthdr ipv6-icmp icmpv6 type 147 counter accept comment "mobile-prefix-advertisement"
225 type filter hook output priority filter
230 ct state { related, established } accept
232 ip protocol icmp counter accept
233 ip daddr 224.0.0.0/4 udp dport 1900 counter accept comment "UPnP"
234 meta skuid 0 udp dport 33434-33523 counter accept comment "traceroute"
236 ${lib.optionalString networking.enableIPv6 ''
237 ip6 nexthdr ipv6-icmp jump accept-icmpv6
239 # Connectivity checking messages
240 ip6 nexthdr ipv6-icmp icmpv6 type echo-request counter accept
241 ip6 nexthdr ipv6-icmp icmpv6 type echo-reply counter accept
242 ip6 nexthdr ipv6-icmp log level err prefix "fw2net: icmpv6: catch all: " counter reject
244 ip6 daddr ff02::1:2/64 udp dport 547 counter accept comment "DHCPv6"
247 ct state invalid log level warn prefix "fw2net: invalid: " counter drop
249 tcp dport 22 counter accept comment "SSH"
251 # Some .nix append gotos here with: add rule inet filter output oifname ... goto ...
256 type nat hook prerouting priority filter
260 type nat hook postrouting priority srcnat