]> Git — Sourcephile - sourcephile-nix.git/blob - machines/losurdo/system.nix
nix: relax GC to weekly on losurdo
[sourcephile-nix.git] / machines / losurdo / system.nix
1 { pkgs, lib, config, ... }:
2 let
3 inherit (config) networking;
4 in
5 {
6 # This value determines the NixOS release with which your system is to be
7 # compatible, in order to avoid breaking some software such as database servers.
8 # You should change this only after NixOS release notes say you should.
9 system.stateVersion = "19.09"; # Did you read the comment?
10
11 # Avoid the use of systemd-run --user --scope tmux
12 # and let mosh work smoothly.
13 services.logind.killUserProcesses = false;
14
15 nix.gc.dates = "weekly";
16 nix.gc.options = "--delete-older-than 7d";
17
18 services.unbound.enable = true;
19 documentation.nixos = {
20 enable = false; # NOTE: useless on a server, and CPU intensive.
21 };
22
23 environment.systemPackages = with pkgs; [
24 cryptsetup
25 direnv
26 file
27 fio
28 gdb
29 git
30 gptfdisk
31 #hey
32 home-manager
33 lm_sensors
34 rsync
35 smartctl-tbw
36 socat
37 sanoid
38 #iptables-nftables-compat
39 gnupg
40 miniupnpc
41 audit
42 python
43 ];
44 }