]> Git — Sourcephile - julm/julm-nix.git/blob - homes/julm/hosts/oignon.nix
nix: revamp in profiles
[julm/julm-nix.git] / homes / julm / hosts / oignon.nix
1 { pkgs, lib, config, ... }:
2 {
3 imports = [
4 ../../../profiles/chat.nix
5 ../../../profiles/developing.nix
6 ../../../profiles/drawing.nix
7 ../../../profiles/gaming.nix
8 ../../../profiles/graphical.nix
9 ../../../profiles/networking.nix
10 ../../../profiles/office.nix
11 ../../../profiles/security.nix
12 ../../../profiles/sharing.nix
13 ../../../profiles/system.nix
14 ../../../profiles/video.nix
15 ../../../profiles/web.nix
16 ];
17 programs.bash.shellAliases.riseup = "sudo ip netns exec riseup sudo -u $USER PULSE_SERVER=/run/user/$(id -u $USER)/pulse/native";
18 programs.bash.shellAliases.firefox = "riseup firefox";
19 programs.gpg.homedir = "${config.home.homeDirectory}/documents/sec/.gnupg";
20 home.sessionVariables = {
21 PASSWORD_STORE_DIR = "$HOME/documents/sec/.password-store";
22 };
23 home.packages = [
24 pkgs.gpsbabel
25 (pkgs.qgis.override { extraPythonPackages = (ps: [
26 ps.pyqt5_with_qtwebkit
27 ]); })
28 #pkgs.libva-utils
29 #pkgs.ristretto
30 ];
31 xsession.enable = true;
32 xsession.windowManager.xmonad.enable = true;
33 }