1 { config, pkgs, lib, ... }:
4 ../nixos/profiles/graphical.nix
5 ../nixos/profiles/lang-fr.nix
6 ../nixos/profiles/laptop.nix
7 ../nixos/profiles/printing.nix
8 ../nixos/profiles/home.nix
15 # Lower kernel's security for better performances
16 security.kernel.mitigations = "off";
18 home-manager.users.sevy = {
19 imports = [ ../homes/sevy.nix ];
24 # Put the hashedPassword in /nix/store, but it will also be in /etc/passwd
25 # which is already world readable.
26 hashedPassword = lib.readFile patate/users/sevy/login/hashedPassword.clear;
29 config.services.davfs2.davGroup
44 #"ssh://nix-ssh@losurdo.wg?priority=30"
45 #"ssh://nix-ssh@oignon.wg?priority=10"
47 trusted-public-keys = map lib.readFile [
48 ../users/root/nix/losurdo.pub
49 ../users/root/nix/oignon.pub
54 environment.systemPackages = [
55 pkgs.riseup-vpn # Can't be installed by home-manager because it needs to install policy-kit rules
66 services.displayManager = {
67 defaultSession = "mate";
69 user = config.users.users.sevy.name;
73 virtualisation.virtualbox.host.enable = true;
75 # This value determines the NixOS release with which your system is to be
76 # compatible, in order to avoid breaking some software such as database
77 # servers. You should change this only after NixOS release notes say you should.
78 system.stateVersion = "20.03"; # Did you read the comment?