]> Git — Sourcephile - julm/julm-nix.git/blob - hosts/patate.nix
aubergine: nftables: fix DHCP renewal
[julm/julm-nix.git] / hosts / patate.nix
1 { config, pkgs, lib, ... }:
2 {
3 imports = [
4 ../nixos/profiles/graphical.nix
5 ../nixos/profiles/lang-fr.nix
6 ../nixos/profiles/laptop.nix
7 ../nixos/profiles/printing.nix
8 ../nixos/profiles/home.nix
9 patate/backup.nix
10 patate/hardware.nix
11 patate/nebula.nix
12 patate/networking.nix
13 ];
14
15 # Lower kernel's security for better performances
16 security.kernel.mitigations = "off";
17
18 home-manager.users.sevy = {
19 imports = [ ../homes/sevy.nix ];
20 };
21 users.users.sevy = {
22 isNormalUser = true;
23 uid = 1000;
24 # Put the hashedPassword in /nix/store, but it will also be in /etc/passwd
25 # which is already world readable.
26 hashedPassword = lib.readFile patate/users/sevy/login/hashedPassword.clear;
27 extraGroups = [
28 "adbusers"
29 config.services.davfs2.davGroup
30 "lp"
31 "networkmanager"
32 "scanner"
33 "systemd-journal"
34 "tor"
35 "vboxusers"
36 "video"
37 "wheel"
38 ];
39 };
40
41 nix = {
42 settings = {
43 substituters = [
44 #"ssh://nix-ssh@losurdo.wg?priority=30"
45 #"ssh://nix-ssh@oignon.wg?priority=10"
46 ];
47 trusted-public-keys = map lib.readFile [
48 ../users/root/nix/losurdo.pub
49 ../users/root/nix/oignon.pub
50 ];
51 };
52 };
53
54 environment.systemPackages = [
55 pkgs.riseup-vpn # Can't be installed by home-manager because it needs to install policy-kit rules
56 ];
57
58 services.xserver = {
59 desktopManager = {
60 mate.enable = true;
61 xfce.enable = true;
62 xterm.enable = false;
63 };
64 };
65
66 services.displayManager = {
67 defaultSession = "mate";
68 autoLogin = {
69 user = config.users.users.sevy.name;
70 };
71 };
72
73 virtualisation.virtualbox.host.enable = true;
74
75 # This value determines the NixOS release with which your system is to be
76 # compatible, in order to avoid breaking some software such as database
77 # servers. You should change this only after NixOS release notes say you should.
78 system.stateVersion = "20.03"; # Did you read the comment?
79 }