]> Git — Sourcephile - julm/julm-nix.git/blob - homes/julm/hosts/oignon.nix
oignon: install pandoc and texlive
[julm/julm-nix.git] / homes / julm / hosts / oignon.nix
1 { pkgs, lib, config, ... }:
2 {
3 imports = [
4 ../../../home-manager/profiles/chat.nix
5 ../../../home-manager/profiles/developing.nix
6 ../../../home-manager/profiles/drawing.nix
7 ../../../home-manager/profiles/gaming.nix
8 ../../../home-manager/profiles/gnupg.nix
9 ../../../home-manager/profiles/graphical.nix
10 ../../../home-manager/profiles/networking.nix
11 ../../../home-manager/profiles/office.nix
12 ../../../home-manager/profiles/radio.nix
13 ../../../home-manager/profiles/science.nix
14 ../../../home-manager/profiles/sharing.nix
15 ../../../home-manager/profiles/video.nix
16 ../../../home-manager/profiles/wireless.nix
17
18 ../../../home-manager/profiles/emacs.nix
19 ../../../home-manager/profiles/firefox.nix
20 ../../../home-manager/profiles/xmonad.nix
21 ../../../home-manager/profiles/ghc.nix
22
23 ../mails.nix
24 ];
25 programs.bash.shellAliases.riseup = "sudo ip netns exec riseup sudo -u $USER PULSE_SERVER=/run/user/$(id -u $USER)/pulse/native";
26 programs.gpg.homedir = "${config.home.homeDirectory}/files/sec/.gnupg";
27 home.sessionVariables = {
28 PASSWORD_STORE_DIR = "$HOME/files/sec/.password-store";
29 };
30 home.packages = [
31 #pkgs.chromium
32 pkgs.fluidsynth
33 pkgs.gpsbabel
34 #(pkgs.qgis.override { extraPythonPackages = (ps: [
35 # ps.pyqt5_with_qtwebkit
36 #]); })
37 #pkgs.libva-utils
38 pkgs.pandoc
39 pkgs.texlive.combined.scheme-small
40 #pkgs.ristretto
41 pkgs.xfce.mousepad
42 #pkgs.mate.pluma
43 pkgs.wxmaxima
44 pkgs.espeak-ng
45 pkgs.iodine
46 #pkgs.qsynth
47 ];
48
49 /* Cannot be automounted
50 systemd.user.mounts = {
51 mnt-aubergine = {
52 Unit = {
53 Wants = [
54 "network-online.target"
55 "wireguard-wg-intra.target"
56 ];
57 After = [
58 "network-online.target"
59 "wireguard-wg-intra.target"
60 ];
61 };
62 Install = {
63 WantedBy = ["default.target"];
64 };
65 Mount = {
66 What = "julm@aubergine.wg:/";
67 Where = "/mnt/aubergine";
68 Type = "fuse.sshfs";
69 Options = lib.concatStringsSep "," [
70 "user"
71 "uid=julm"
72 "gid=users"
73 "allow_other"
74 "exec" # Override "user"'s noexec
75 "noatime"
76 "nosuid"
77 "noauto"
78 "dir_cache=no"
79 #"reconnect"
80 "x-gvfs-hide"
81 # Does not work for user mounts
82 #"x-systemd.automount"
83 "IdentityFile=/home/julm/.ssh/id_ed25519"
84 #"Compression=yes" # YMMV
85 # Disconnect approximately 2*15=30 seconds after a network failure
86 "ServerAliveCountMax=1"
87 "ServerAliveInterval=15"
88 ];
89 };
90 };
91 };
92 */
93 /*
94 Automounting does not work without root privileges
95 systemd.user.automounts = {
96 mnt-aubergine = {
97 Install = {
98 WantedBy = ["user.target"];
99 };
100 Unit = {
101 };
102 Automount = {
103 Where = "/mnt/aubergine";
104 TimeoutIdleSec = "5 min";
105 };
106 };
107 };
108 */
109 }