]> Git — Sourcephile - julm/julm-nix.git/blob - homes/julm/hosts/oignon.nix
oignon: remove texlive globally
[julm/julm-nix.git] / homes / julm / hosts / oignon.nix
1 { pkgs, lib, config, ... }:
2 {
3 imports = [
4 ../../../home-manager/profiles/chat.nix
5 ../../../home-manager/profiles/developing.nix
6 ../../../home-manager/profiles/drawing.nix
7 ../../../home-manager/profiles/gaming.nix
8 ../../../home-manager/profiles/gnupg.nix
9 ../../../home-manager/profiles/graphical.nix
10 ../../../home-manager/profiles/networking.nix
11 ../../../home-manager/profiles/radio.nix
12 ../../../home-manager/profiles/science.nix
13 ../../../home-manager/profiles/video.nix
14 ../../../home-manager/profiles/yt-dlp.nix
15 ../../../home-manager/profiles/mpv.nix
16 ../../../home-manager/profiles/wireless.nix
17
18 ../../../home-manager/profiles/emacs.nix
19 ../../../home-manager/profiles/firefox.nix
20 ../../../home-manager/profiles/xmonad.nix
21 ../../../home-manager/profiles/ghc.nix
22
23 ../mails.nix
24 ];
25 programs.bash.shellAliases.riseup = "sudo ip netns exec riseup sudo -u $USER PULSE_SERVER=/run/user/$(id -u $USER)/pulse/native";
26 programs.gpg.homedir = "${config.home.homeDirectory}/files/sec/.gnupg";
27 home.sessionVariables = {
28 PASSWORD_STORE_DIR = "$HOME/files/sec/.password-store";
29 };
30 home.packages = [
31 pkgs.ghostscript
32 #pkgs.go-mtpfs
33 pkgs.ntfs3g
34 pkgs.p7zip
35 pkgs.unar
36 pkgs.pdftk
37 pkgs.vips
38 pkgs.poppler_utils
39 # psnup conflicts with pkgs.texlive.combined.scheme-*
40 (lib.lowPrio pkgs.psutils)
41 pkgs.ink
42 pkgs.djview
43 pkgs.qpdf
44 pkgs.libreoffice
45 pkgs.calibre
46 pkgs.evince
47 pkgs.xsane
48 #pkgs.stig
49 pkgs.gthumb
50 pkgs.thunderbird
51 #pkgs.chromium
52 pkgs.fluidsynth
53 pkgs.gpsbabel
54 #(pkgs.qgis.override { extraPythonPackages = (ps: [
55 # ps.pyqt5_with_qtwebkit
56 #]); })
57 #pkgs.libva-utils
58 pkgs.pandoc
59 pkgs.pdf2djvu
60 #pkgs.ristretto
61 pkgs.xfce.mousepad
62 #pkgs.mate.pluma
63 pkgs.wxmaxima
64 pkgs.espeak-ng
65 pkgs.iodine
66 #pkgs.qsynth
67 ];
68
69 /* Cannot be automounted
70 systemd.user.mounts = {
71 mnt-aubergine = {
72 Unit = {
73 Wants = [
74 "network-online.target"
75 "wireguard-wg-intra.target"
76 ];
77 After = [
78 "network-online.target"
79 "wireguard-wg-intra.target"
80 ];
81 };
82 Install = {
83 WantedBy = ["default.target"];
84 };
85 Mount = {
86 What = "julm@aubergine.wg:/";
87 Where = "/mnt/aubergine";
88 Type = "fuse.sshfs";
89 Options = lib.concatStringsSep "," [
90 "user"
91 "uid=julm"
92 "gid=users"
93 "allow_other"
94 "exec" # Override "user"'s noexec
95 "noatime"
96 "nosuid"
97 "noauto"
98 "dir_cache=no"
99 #"reconnect"
100 "x-gvfs-hide"
101 # Does not work for user mounts
102 #"x-systemd.automount"
103 "IdentityFile=/home/julm/.ssh/id_ed25519"
104 #"Compression=yes" # YMMV
105 # Disconnect approximately 2*15=30 seconds after a network failure
106 "ServerAliveCountMax=1"
107 "ServerAliveInterval=15"
108 ];
109 };
110 };
111 };
112 */
113 /*
114 Automounting does not work without root privileges
115 systemd.user.automounts = {
116 mnt-aubergine = {
117 Install = {
118 WantedBy = ["user.target"];
119 };
120 Unit = {
121 };
122 Automount = {
123 Where = "/mnt/aubergine";
124 TimeoutIdleSec = "5 min";
125 };
126 };
127 };
128 */
129 }