1 { config, pkgs, lib, inputs, hostName, ... }:
2 let inherit (config.users) users; in
5 ../profiles/dnscrypt-proxy2.nix
10 home-manager.users.sevy = {
11 imports = [ ../homes/sevy.nix ];
13 host.hardware = ["ThinkPad" "X200"];
15 systemd.services.home-manager-julm.postStart = ''
16 ${pkgs.nix}/bin/nix-env --delete-generations +1 --profile /nix/var/nix/profiles/per-user/sevy/home-manager
18 users.mutableUsers = false;
22 # Put the hashedPassword in /nix/store, but it will also be in /etc/passwd
23 # which is already world readable.
24 hashedPassword = lib.readFile ../private/world/sevy/hashedPassword;
27 config.services.davfs2.davGroup
41 auto-optimise-store = true
46 options = "--delete-older-than 7d";
49 "nixpkgs=/etc/nixpkgs"
50 "nixpkgs-overlays=/etc/nixpkgs-overlays/overlays.nix"
52 trustedUsers = [ users.sevy.name ];
54 "https://nix-localcache.sourcephile.fr"
55 #"ssh://nix-ssh@192.168.0.115" # FIXME: use wireguard
57 binaryCachePublicKeys = [
58 "losurdo.sourcephile.fr-1:XGeaIE2AA2mZskSZ5bIDrfx53q+TDDWJOUEpZDX7los="
59 "oignon.sourcephile.fr:slxL7XLsGXlD1r6gvw1imL5uQntW0TTlQgGQt3LBJgQ="
62 services.openssh.passwordAuthentication = false;
67 environment.etc."nixpkgs".source = pkgs.path;
68 environment.etc."nixpkgs-overlays".source = inputs.self + "/nixpkgs";
70 documentation.nixos.enable = true;
71 time.timeZone = "Europe/Paris";
72 i18n.defaultLocale = "fr_FR.UTF-8";
73 console.font = "Lat2-Terminus16";
74 console.keyMap = "fr";
78 domain = "localdomain";
85 #backend = "wpa_supplicant";
93 51413 # transmission-gtk
97 51413 # transmission-gtk
105 hardware.pulseaudio.enable = true;
106 hardware.sane.enable = true;
107 hardware.sane.extraBackends = [ pkgs.hplipWithPlugin ];
109 environment.variables = {
112 SYSTEMD_LESS = "FKMRX";
117 interactiveShellInit = ''
118 bind '"\e[A":history-search-backward'
119 bind '"\e[B":history-search-forward'
121 # Ignore duplicate commands, ignore commands starting with a space
122 export HISTCONTROL=erasedups:ignorespace
123 export HISTSIZE=42000
124 # Append to the history instead of overwriting (good for multiple connections)
128 mkcd () { mkdir -p "$1"; cd "$1"; }
131 then sudo tee /proc/acpi/ibm/fan <<<"level $1"
132 else grep '^\(level\|speed\):' /proc/acpi/ibm/fan
139 grep = "grep --color";
142 ls = "ls --color=tty";
143 mem = "ps -e -orss=,user=,args= | sort -b -k1,1n";
146 st="sudo systemctl status";
147 u="systemctl --user";
148 j="sudo journalctl -u";
149 jb="sudo journalctl -b";
151 nix-history="sudo nix-env --list-generations --profile /nix/var/nix/profiles/system";
153 sshfs = "sshfs -o ServerAliveInterval=15 -o reconnect -f";
163 openFirewall = false;
173 fileSystems."/home/sevy/mnt/ilico/severine" = {
174 device = "https://nuage.ilico.org/remote.php/dav/files/severine/";
177 let conf = pkgs.writeText "davfs2.conf" ''
178 backup_dir /home/sevy/Documents/EnTransfert/ilico/severine
179 cache_dir /home/sevy/.cache/davfs2/ilico/severine
181 [ "conf=${conf}" "user" "noexec" "nosuid" "noauto" ]; # "x-systemd.automount"
184 packages = [ pkgs.gnome3.dconf ];
189 services.journald = {
192 MaxRetentionSec=1month
197 services.physlock = {
200 # NOTE: xfconf-query -c xfce4-session -p /general/LockCommand -s "physlock" --create -t string
202 services.printing = {
211 # Allow members of the "adbusers" group to mount Android devices via MTP
212 pkgs.android-udev-rules
218 xkbOptions = "eurosign:e";
219 libinput.enable = true;
224 #pkgs.xfce.thunar-archive-plugin
227 xterm.enable = false;
230 defaultSession = "xfce";
233 user = users.sevy.name;
238 virtualisation.virtualbox.host.enable = true;
240 # This value determines the NixOS release with which your system is to be
241 # compatible, in order to avoid breaking some software such as database
242 # servers. You should change this only after NixOS release notes say you should.
243 system.stateVersion = "20.03"; # Did you read the comment?