]> Git — Sourcephile - julm/julm-nix.git/blob - home-manager/profiles/urxvt.nix
urxvt: remove colon from cutchars because it's in URL schemes
[julm/julm-nix.git] / home-manager / profiles / urxvt.nix
1 { pkgs, lib, config, ... }:
2 {
3 home.packages = [
4 pkgs.rxvt-unicode
5 ];
6 xresources.properties = {
7 "URxvt*background" = "black";
8 "URxvt*buffered" = "true";
9 "URxvt*cursorBlink" = "on";
10 "URxvt*cursorColor" = "#00B10B";
11 "URxvt*cursorColor2" = "black";
12 "URxvt*cutchars" = ''"()*,;<>[]{}|│`\"'#:、。"'';
13 "URxvt*depth" = "32";
14 "URxvt*fading" = "0";
15 "URxvt*font" = "xft:DejaVu Sans Mono:size=6";
16 "URxvt*font-size.step" = "1";
17 "URxvt*foreground" = "white";
18 "URxvt*geometry" = "61x20";
19 "URxvt*highlightColor" = "red";
20 "URxvt*insecure" = "True";
21 "URxvt*internalBorder" = "2";
22 "URxvt*iso14755_52" = "False";
23 "URxvt*jumpScroll" = "on";
24 "URxvt*keysym.C-Down" = "perl:font-size:decrease";
25 "URxvt*keysym.C-ISO_Left_Tab" = "\\033[27;6;9~";
26 "URxvt*keysym.C-S-Down" = "perl:font-size:decglobal";
27 "URxvt*keysym.C-S-Up" = "perl:font-size:incglobal";
28 "URxvt*keysym.C-Tab" = "\\033[27;5;9~";
29 "URxvt*keysym.C-Up" = "perl:font-size:increase";
30 "URxvt*keysym.KP_End" = "\\033[4~";
31 "URxvt*keysym.KP_Enter" = "\\n";
32 "URxvt*keysym.KP_Home" = "\\033[1~";
33 "URxvt*letterSpace" = "0";
34 "URxvt*lineSpace" = "0";
35 "URxvt*meta8" = "False";
36 "URxvt*perl-ext" = "default";
37 "URxvt*perl-ext-common" = "default,font-size";
38 "URxvt*pointerColor" = "green";
39 "URxvt*pointerColor2" = "black";
40 "URxvt*reverseVideo" = "false";
41 "URxvt*saveLines" = "0";
42 "URxvt*scrollBar_floating" = "on";
43 "URxvt*scrollBar_right" = "on";
44 "URxvt*scrollColor" = "grey20";
45 "URxvt*scrollTtyKeypress" = "on";
46 "URxvt*scrollTtyOutput" = "off";
47 "URxvt*scrollWithBuffer" = "on";
48 "URxvt*scrollbar*foreground" = "blue";
49 "URxvt*scrollstyle" = "plain";
50 "URxvt*termName" = "xterm-256color";
51 "URxvt*troughColor" = "blue";
52 "URxvt*urgentOnBell" = "true";
53 "URxvt*visualBell" = "off";
54 /*
55 !URxvt.urlLauncher: elinks
56 !URxvt*font: xft:DejaVu Sans Mono:pixelsize=9:antialias=true
57 !URxvt*font: xft:DejaVu Sans Mono:size=6.38:weight=medium:antialias=true:hintstyle=100:autohint=0,xft:unifont,xft:freemono:pixelsize=13,xft:Code2000:antialias=false
58 !URxvt*font: xft:DejaVu Sans Mono:pixelsize=24
59 !URxvt*font: xft:Inconsolata:pixelsize=10
60 !URxvt*font: xft:Fira Code:pixelsize=10
61 !URxvt*scrollWithBuffer: true
62 !: hinting=true:slant=0:weight=50
63 !URxvt*boldFont: xft:DejaVu Sans Mono:bold:pixelsize=9:antialias=true:hinting=true
64 !urxvt*boldColors: on
65 ! Allow switching of font sizes
66 !URxvt.keysym.C-M-minus: command:\033]710;xft:Terminus-8:slant=0:weight=80,xft:DejaVu\ Sans\ Mono-9:slant=0:weight=80,xft:Inconsolata-10,x:-schumacher-clean-medium-r-normal-*-12-*-*-*-c-*-iso10646-1,x:-misc-fixed-medium-r-semicondensed-*-13-*-*-*-c-*-iso10646-1,x:-b&h-lucidatypewriter-medium-r-normal-*-12-*-*-*-m-*-iso10646-1\007\033]711;xft:Terminus-8:slant=0:weight=200,xft:DejaVu\ Sans\ Mono-9:slant=0:weight=200,x:-misc-fixed-bold-r-semicondensed-*-13-*-*-*-c-*-iso10646-1,x:-b&h-lucidatypewriter-bold-r-normal-*-12-*-*-*-m-*-iso10646-1\007\033]712;xft:Terminus-8:slant=110:weight=80,xft:DejaVu Sans Mono-8:slant=110:weight=80\007\033]713;xft:Terminus-8:slant=110:weight=200,xft:DejaVu Sans Mono-8:slant=110:weight=200\007
67 !URxvt.keysym.C-M-equal: command:\033]710;xft:Terminus-14:slant=0:weight=80,xft:DejaVu\ Sans\ Mono-14:slant=0:weight=80,xft:Inconsolata-16,x:-gnu-unifont-medium-r-normal-*-17-*-*-*-c-*-iso10646-1,x:-b&h-lucidatypewriter-medium-r-normal-*-17-*-*-*-m-*-iso10646-1\007\033]711;xft:Terminus-14:slant=0:weight=200,xft:DejaVu\ Sans\ Mono-14:slant=0:weight=200,x:-misc-fixed-medium-r-normal-*-20-*-*-*-c-*-iso10646-1,x:-b&h-lucidatypewriter-*-r-normal-*-17-*-*-*-m-*-iso10646-1\007\033]712;xft:Terminus-14:slant=110:weight=80,xft:DejaVu Sans Mono-14:slant=110:weigth=80\007\033]713;xft:Terminus-14:slant=110:weight=200,xft:DejaVu Sans Mono-14:slant=110:weight=200\007
68 !URxvt.iso14755: False
69 !URxvt.perl-ext-common: default,matcher
70 */
71 };
72 }