1 { config, pkgs, lib, ... }:
4 ../nixos/profiles/dnscrypt-proxy2.nix
5 ../nixos/profiles/graphical.nix
6 ../nixos/profiles/lang-fr.nix
7 ../nixos/profiles/networking.nix
8 ../nixos/profiles/printing.nix
9 ../nixos/profiles/security.nix
10 ../nixos/profiles/system.nix
11 ../nixos/profiles/wireguard/wg-intra.nix
17 home-manager.users.sevy = {
18 imports = [ ../homes/sevy.nix ];
19 host.hardware = [ "ThinkPad" "X200" ];
21 systemd.services.home-manager-sevy.postStart = ''
22 ${pkgs.nix}/bin/nix-env --delete-generations +1 --profile /nix/var/nix/profiles/per-user/sevy/home-manager
27 # Put the hashedPassword in /nix/store, but it will also be in /etc/passwd
28 # which is already world readable.
29 hashedPassword = lib.readFile ../private/world/sevy/hashedPassword;
32 config.services.davfs2.davGroup
46 trusted-users = [ config.users.users."sevy".name ];
48 #"ssh://nix-ssh@losurdo.wg?priority=30"
49 "ssh://nix-ssh@oignon.wg?priority=10"
51 trusted-public-keys = map lib.readFile [
52 ../private/shared/nix/losurdo.pub
53 ../private/shared/nix/oignon.pub
58 environment.systemPackages = [
59 pkgs.riseup-vpn # Can't be installed by home-manager because it needs to install policy-kit rules
65 # NOTE: xfconf-query -c xfce4-session -p /general/LockCommand -s "physlock" --create -t string
75 defaultSession = "mate";
77 user = config.users.users.sevy.name;
82 virtualisation.virtualbox.host.enable = true;
84 # This value determines the NixOS release with which your system is to be
85 # compatible, in order to avoid breaking some software such as database
86 # servers. You should change this only after NixOS release notes say you should.
87 system.stateVersion = "20.03"; # Did you read the comment?