]> Git — Sourcephile - julm/julm-nix.git/blob - homes/julm/hosts/oignon.nix
radicle: use nixpkgs' radicle-node
[julm/julm-nix.git] / homes / julm / hosts / oignon.nix
1 { pkgs, lib, config, ... }:
2 {
3 imports = [
4 ../../../home-manager/profiles/chat.nix
5 ../../../home-manager/profiles/developing.nix
6 ../../../home-manager/profiles/direnv.nix
7 ../../../home-manager/profiles/drawing.nix
8 ../../../home-manager/profiles/gaming.nix
9 ../../../home-manager/profiles/git.nix
10 ../../../home-manager/profiles/gnupg.nix
11 ../../../home-manager/profiles/gnupg.nix
12 ../../../home-manager/profiles/graphical.nix
13 ../../../home-manager/profiles/lf.nix
14 ../../../home-manager/profiles/mpv.nix
15 ../../../home-manager/profiles/networking.nix
16 ../../../home-manager/profiles/nix.nix
17 ../../../home-manager/profiles/radio.nix
18 ../../../home-manager/profiles/science.nix
19 ../../../home-manager/profiles/video.nix
20 ../../../home-manager/profiles/wireless.nix
21 ../../../home-manager/profiles/yt-dlp.nix
22
23 ../../../home-manager/profiles/emacs.nix
24 ../../../home-manager/profiles/firefox.nix
25 ../../../home-manager/profiles/xmonad.nix
26 ../../../home-manager/profiles/ghc.nix
27
28 ../mails.nix
29 ];
30 programs.bash.shellAliases.riseup = "sudo ip netns exec riseup sudo -u $USER PULSE_SERVER=/run/user/$(id -u $USER)/pulse/native";
31 programs.gpg.homedir = "${config.home.homeDirectory}/files/sec/.gnupg";
32 home.sessionVariables = {
33 PASSWORD_STORE_DIR = "$HOME/files/sec/.password-store";
34 };
35 home.packages = [
36 pkgs.radicle-node
37 pkgs.radicle-httpd
38 pkgs.ghostscript
39 #pkgs.go-mtpfs
40 pkgs.ntfs3g
41 pkgs.p7zip
42 pkgs.unar
43 pkgs.pdftk
44 pkgs.vips
45 pkgs.poppler_utils
46 # psnup conflicts with pkgs.texlive.combined.scheme-*
47 (lib.lowPrio pkgs.psutils)
48 pkgs.ink
49 pkgs.djview
50 pkgs.qpdf
51 pkgs.libreoffice
52 pkgs.calibre
53 pkgs.zotero
54 pkgs.evince
55 pkgs.marble
56 pkgs.gcompris
57 pkgs.frozen-bubble
58 pkgs.neverball
59 pkgs.tuxpaint
60 pkgs.xsane
61 #pkgs.stig
62 pkgs.gthumb
63 pkgs.thunderbird
64 #pkgs.chromium
65 pkgs.fluidsynth
66 pkgs.gpsbabel
67 #(pkgs.qgis.override { extraPythonPackages = (ps: [
68 # ps.pyqt5_with_qtwebkit
69 #]); })
70 #pkgs.libva-utils
71 pkgs.otpclient
72 pkgs.pandoc
73 pkgs.pdf2djvu
74 #pkgs.ristretto
75 pkgs.xfce.mousepad
76 #pkgs.mate.pluma
77 pkgs.wxmaxima
78 pkgs.espeak-ng
79 pkgs.iodine
80 #pkgs.qsynth
81 ];
82
83 /* Cannot be automounted
84 systemd.user.mounts = {
85 mnt-aubergine = {
86 Unit = {
87 Wants = [
88 "network-online.target"
89 "wireguard-wg-intra.target"
90 ];
91 After = [
92 "network-online.target"
93 "wireguard-wg-intra.target"
94 ];
95 };
96 Install = {
97 WantedBy = ["default.target"];
98 };
99 Mount = {
100 What = "julm@aubergine.sp:/";
101 Where = "/mnt/aubergine";
102 Type = "fuse.sshfs";
103 Options = lib.concatStringsSep "," [
104 "user"
105 "uid=julm"
106 "gid=users"
107 "allow_other"
108 "exec" # Override "user"'s noexec
109 "noatime"
110 "nosuid"
111 "noauto"
112 "dir_cache=no"
113 #"reconnect"
114 "x-gvfs-hide"
115 # Does not work for user mounts
116 #"x-systemd.automount"
117 "IdentityFile=/home/julm/.ssh/id_ed25519"
118 #"Compression=yes" # YMMV
119 # Disconnect approximately 2*15=30 seconds after a network failure
120 "ServerAliveCountMax=1"
121 "ServerAliveInterval=15"
122 ];
123 };
124 };
125 };
126 */
127 /*
128 Automounting does not work without root privileges
129 systemd.user.automounts = {
130 mnt-aubergine = {
131 Install = {
132 WantedBy = ["user.target"];
133 };
134 Unit = {
135 };
136 Automount = {
137 Where = "/mnt/aubergine";
138 TimeoutIdleSec = "5 min";
139 };
140 };
141 };
142 */
143 }