1 { config, pkgs, lib, inputs, hostName, ... }:
2 let inherit (config.users) users; in
5 ../profiles/dnscrypt-proxy2.nix
10 home-manager.users.sevy = {
11 imports = [ ../homes/sevy.nix ];
13 host.hardware = ["ThinkPad" "X200"];
15 systemd.services.home-manager-julm.postStart = ''
16 ${pkgs.nix}/bin/nix-env --delete-generations +1 --profile /nix/var/nix/profiles/per-user/sevy/home-manager
18 users.mutableUsers = false;
22 # Put the hashedPassword in /nix/store, but it will also be in /etc/passwd
23 # which is already world readable.
24 hashedPassword = lib.readFile ../secrets/sevy/hashedPassword;
40 auto-optimise-store = true
45 options = "--delete-older-than 7d";
48 "nixpkgs=/etc/nixpkgs"
49 "nixpkgs-overlays=/etc/nixpkgs-overlays/overlays.nix"
51 trustedUsers = [ users.sevy.name ];
53 environment.etc."nixpkgs".source = pkgs.path;
54 environment.etc."nixpkgs-overlays".source = inputs.self + "/nixpkgs";
59 documentation.nixos.enable = true;
60 time.timeZone = "Europe/Paris";
61 i18n.defaultLocale = "fr_FR.UTF-8";
62 console.font = "Lat2-Terminus16";
63 console.keyMap = "fr";
67 domain = "localdomain";
74 #backend = "wpa_supplicant";
82 51413 # transmission-gtk
86 51413 # transmission-gtk
94 hardware.pulseaudio.enable = true;
95 hardware.sane.enable = true;
96 hardware.sane.extraBackends = [ pkgs.hplipWithPlugin ];
98 environment.variables = {
101 SYSTEMD_LESS = "FKMRX";
106 interactiveShellInit = ''
107 bind '"\e[A":history-search-backward'
108 bind '"\e[B":history-search-forward'
110 # Ignore duplicate commands, ignore commands starting with a space
111 export HISTCONTROL=erasedups:ignorespace
112 export HISTSIZE=42000
113 # Append to the history instead of overwriting (good for multiple connections)
117 mkcd () { mkdir -p "$1"; cd "$1"; }
120 then sudo tee /proc/acpi/ibm/fan <<<"level $1"
121 else grep '^\(level\|speed\):' /proc/acpi/ibm/fan
128 grep = "grep --color";
131 ls = "ls --color=tty";
132 mem = "ps -e -orss=,user=,args= | sort -b -k1,1n";
135 st="sudo systemctl status";
136 u="systemctl --user";
137 j="sudo journalctl -u";
138 jb="sudo journalctl -b";
140 nix-history="sudo nix-env --list-generations --profile /nix/var/nix/profiles/system";
142 sshfs = "sshfs -o ServerAliveInterval=15 -o reconnect -f";
153 openFirewall = false;
159 packages = [ pkgs.gnome3.dconf ];
167 MaxRetentionSec=1month
175 # NOTE: xfconf-query -c xfce4-session -p /general/LockCommand -s "physlock" --create -t string
186 # Allow members of the "adbusers" group to mount Android devices via MTP
187 pkgs.android-udev-rules
193 xkbOptions = "eurosign:e";
194 libinput.enable = true;
199 #pkgs.xfce.thunar-archive-plugin
202 xterm.enable = false;
205 defaultSession = "xfce";
208 user = users.sevy.name;
214 virtualisation.virtualbox.host.enable = true;
216 # This value determines the NixOS release with which your system is to be
217 # compatible, in order to avoid breaking some software such as database
218 # servers. You should change this only after NixOS release notes say you should.
219 system.stateVersion = "20.03"; # Did you read the comment?