1 { config, pkgs, lib, inputs, hostName, ... }:
2 let inherit (config.users) users; in
5 ../profiles/dnscrypt-proxy2.nix
10 home-manager.users.sevy = {
11 imports = [ ../homes/sevy.nix ];
13 host.hardware = ["ThinkPad" "X200"];
15 systemd.services.home-manager-julm.postStart = ''
16 ${pkgs.nix}/bin/nix-env --delete-generations +1 --profile /nix/var/nix/profiles/per-user/sevy/home-manager
18 users.mutableUsers = false;
22 # Put the hashedPassword in /nix/store, but it will also be in /etc/passwd
23 # which is already world readable.
24 hashedPassword = lib.readFile ../secrets/sevy/hashedPassword;
40 auto-optimise-store = true
45 options = "--delete-older-than 7d";
48 "nixpkgs=/etc/nixpkgs"
49 "nixpkgs-overlays=/etc/nixpkgs-overlays/overlays.nix"
51 trustedUsers = [ users.sevy.name ];
53 environment.etc."nixpkgs".source = pkgs.path;
54 environment.etc."nixpkgs-overlays".source = inputs.self + "/nixpkgs";
59 documentation.nixos.enable = true;
60 time.timeZone = "Europe/Paris";
61 i18n.defaultLocale = "fr_FR.UTF-8";
62 console.font = "Lat2-Terminus16";
63 console.keyMap = "fr";
67 domain = "localdomain";
74 #backend = "wpa_supplicant";
81 51413 # transmission-gtk
85 51413 # transmission-gtk
93 hardware.pulseaudio.enable = true;
94 hardware.sane.enable = true;
95 hardware.sane.extraBackends = [ pkgs.hplipWithPlugin ];
97 environment.variables = {
100 SYSTEMD_LESS = "FKMRX";
105 interactiveShellInit = ''
106 bind '"\e[A":history-search-backward'
107 bind '"\e[B":history-search-forward'
109 # Ignore duplicate commands, ignore commands starting with a space
110 export HISTCONTROL=erasedups:ignorespace
111 export HISTSIZE=42000
112 # Append to the history instead of overwriting (good for multiple connections)
116 mkcd () { mkdir -p "$1"; cd "$1"; }
119 then sudo tee /proc/acpi/ibm/fan <<<"level $1"
120 else grep '^\(level\|speed\):' /proc/acpi/ibm/fan
127 grep = "grep --color";
130 ls = "ls --color=tty";
131 mem = "ps -e -orss=,user=,args= | sort -b -k1,1n";
134 st="sudo systemctl status";
135 u="systemctl --user";
136 j="sudo journalctl -u";
137 jb="sudo journalctl -b";
139 nix-history="sudo nix-env --list-generations --profile /nix/var/nix/profiles/system";
141 sshfs = "sshfs -o ServerAliveInterval=15 -o reconnect -f";
154 packages = [ pkgs.gnome3.dconf ];
162 MaxRetentionSec=1month
170 # NOTE: xfconf-query -c xfce4-session -p /general/LockCommand -s "physlock" --create -t string
181 # Allow members of the "adbusers" group to mount Android devices via MTP
182 pkgs.android-udev-rules
188 xkbOptions = "eurosign:e";
189 libinput.enable = true;
194 #pkgs.xfce.thunar-archive-plugin
197 xterm.enable = false;
200 defaultSession = "xfce";
203 user = users.sevy.name;
209 virtualisation.virtualbox.host.enable = true;
211 # This value determines the NixOS release with which your system is to be
212 # compatible, in order to avoid breaking some software such as database
213 # servers. You should change this only after NixOS release notes say you should.
214 system.stateVersion = "20.03"; # Did you read the comment?