1 { config, pkgs, lib, inputs, hostName, ... }:
2 let inherit (config.users) users; in
5 ../profiles/dnscrypt-proxy2.nix
9 home-manager.users.sevy = {
10 imports = [ ../homes/sevy.nix ];
12 host.hardware = ["ThinkPad" "X200"];
14 systemd.services.home-manager-julm.postStart = ''
15 ${pkgs.nix}/bin/nix-env --delete-generations +1 --profile /nix/var/nix/profiles/per-user/sevy/home-manager
17 users.mutableUsers = false;
21 # Put the hashedPassword in /nix/store, but it will also be in /etc/passwd
22 # which is already world readable.
23 hashedPassword = lib.readFile ../secrets/sevy/hashedPassword;
39 auto-optimise-store = true
44 options = "--delete-older-than 7d";
47 "nixpkgs=/etc/nixpkgs"
48 "nixpkgs-overlays=/etc/nixpkgs-overlays/overlays.nix"
50 trustedUsers = [ users.sevy.name ];
52 environment.etc."nixpkgs".source = pkgs.path;
53 environment.etc."nixpkgs-overlays".source = inputs.self + "/nixpkgs";
58 documentation.nixos.enable = true;
59 time.timeZone = "Europe/Paris";
60 i18n.defaultLocale = "fr_FR.UTF-8";
61 console.font = "Lat2-Terminus16";
62 console.keyMap = "fr";
66 domain = "localdomain";
73 #backend = "wpa_supplicant";
80 51413 # transmission-gtk
84 51413 # transmission-gtk
92 hardware.pulseaudio.enable = true;
93 hardware.sane.enable = true;
94 hardware.sane.extraBackends = [ pkgs.hplipWithPlugin ];
96 environment.variables = {
99 SYSTEMD_LESS = "FKMRX";
104 interactiveShellInit = ''
105 bind '"\e[A":history-search-backward'
106 bind '"\e[B":history-search-forward'
108 # Ignore duplicate commands, ignore commands starting with a space
109 export HISTCONTROL=erasedups:ignorespace
110 export HISTSIZE=42000
111 # Append to the history instead of overwriting (good for multiple connections)
115 mkcd () { mkdir -p "$1"; cd "$1"; }
118 then sudo tee /proc/acpi/ibm/fan <<<"level $1"
119 else grep '^\(level\|speed\):' /proc/acpi/ibm/fan
126 grep = "grep --color";
129 ls = "ls --color=tty";
130 mem = "ps -e -orss=,user=,args= | sort -b -k1,1n";
133 st="sudo systemctl status";
134 u="systemctl --user";
135 j="sudo journalctl -u";
136 jb="sudo journalctl -b";
138 nix-history="sudo nix-env --list-generations --profile /nix/var/nix/profiles/system";
140 sshfs = "sshfs -o ServerAliveInterval=15 -o reconnect -f";
153 packages = [ pkgs.gnome3.dconf ];
161 MaxRetentionSec=1month
169 # NOTE: xfconf-query -c xfce4-session -p /general/LockCommand -s "physlock" --create -t string
180 extraArgs = [ "--verbose" ];
182 "${hostName}/home/documents" = {
194 # Allow members of the "adbusers" group to mount Android devices via MTP
195 pkgs.android-udev-rules
201 xkbOptions = "eurosign:e";
202 libinput.enable = true;
207 pkgs.xfce.thunar-archive-plugin
210 xterm.enable = false;
213 defaultSession = "xfce";
217 user = users.sevy.name;
224 virtualisation.virtualbox.host.enable = true;
226 # This value determines the NixOS release with which your system is to be
227 # compatible, in order to avoid breaking some software such as database
228 # servers. You should change this only after NixOS release notes say you should.
229 system.stateVersion = "20.03"; # Did you read the comment?