1 { config, pkgs, lib, inputs, hostName, ... }:
3 inherit (config.users) users;
7 ../profiles/dnscrypt-proxy2.nix
11 users.mutableUsers = false;
12 home-manager.users.julm = {
13 imports = [ ../homes/sevy.nix ];
15 host.hardware = ["ThinkPad" "X200"];
17 systemd.services.home-manager-julm.preStart = ''
18 ${pkgs.home-manager}/bin/home-manager expire-generations "-7 days"
23 # Put the hashedPassword in /nix/store, but it will also be in /etc/passwd
24 # which is already world readable.
25 hashedPassword = lib.readFile ../secrets/sevy/hashedPassword;
41 auto-optimise-store = true
46 options = "--delete-older-than 7d";
49 "nixpkgs=/etc/nixpkgs"
50 "nixpkgs-overlays=/etc/nixpkgs-overlays/overlays.nix"
52 trustedUsers = [ users.sevy.name ];
54 environment.etc."nixpkgs".source = pkgs.path;
55 environment.etc."nixpkgs-overlays".source = inputs.self + "/nixpkgs";
61 time.timeZone = "Europe/Paris";
62 i18n.defaultLocale = "fr_FR.UTF-8";
63 console.font = "Lat2-Terminus16";
64 console.keyMap = "fr";
68 domain = "localdomain";
75 #backend = "wpa_supplicant";
82 51413 # transmission-gtk
86 51413 # transmission-gtk
94 hardware.pulseaudio.enable = true;
95 hardware.sane.enable = true;
96 hardware.sane.extraBackends = [ pkgs.hplipWithPlugin ];
98 environment.variables = {
101 SYSTEMD_LESS = "FKMRX";
106 interactiveShellInit = ''
107 bind '"\e[A":history-search-backward'
108 bind '"\e[B":history-search-forward'
110 # Ignore duplicate commands, ignore commands starting with a space
111 export HISTCONTROL=erasedups:ignorespace
112 export HISTSIZE=42000
113 # Append to the history instead of overwriting (good for multiple connections)
117 mkcd () { mkdir -p "$1"; cd "$1"; }
120 then sudo tee /proc/acpi/ibm/fan <<<"level $1"
121 else grep '^\(level\|speed\):' /proc/acpi/ibm/fan
128 grep = "grep --color";
131 ls = "ls --color=tty";
132 mem = "ps -e -orss=,user=,args= | sort -b -k1,1n";
135 st="sudo systemctl status";
136 u="systemctl --user";
137 j="sudo journalctl -u";
138 jb="sudo journalctl -b";
140 nix-history="sudo nix-env --list-generations --profile /nix/var/nix/profiles/system";
142 sshfs = "sshfs -o ServerAliveInterval=15 -o reconnect -f";
155 packages = [ pkgs.gnome3.dconf ];
163 MaxRetentionSec=1month
171 # NOTE: xfconf-query -c xfce4-session -p /general/LockCommand -s "physlock" --create -t string
182 extraArgs = [ "--verbose" ];
184 "${hostName}/home/documents" = {
196 # Allow members of the "adbusers" group to mount Android devices via MTP
197 pkgs.android-udev-rules
203 xkbOptions = "eurosign:e";
204 libinput.enable = true;
207 defaultSession = "xfce";
211 user = users.sevy.name;
219 pkgs.xfce.thunar-archive-plugin
222 xterm.enable = false;
227 virtualisation.virtualbox.host.enable = true;
229 # This value determines the NixOS release with which your system is to be
230 # compatible, in order to avoid breaking some software such as database
231 # servers. You should change this only after NixOS release notes say you should.
232 system.stateVersion = "20.03"; # Did you read the comment?