]> Git — Sourcephile - julm/julm-nix.git/blob - homes/julm/hosts/oignon.nix
hosts: install packages
[julm/julm-nix.git] / homes / julm / hosts / oignon.nix
1 { pkgs, lib, config, ... }:
2 {
3 imports = [
4 ../../../home-manager/profiles/chat.nix
5 ../../../home-manager/profiles/developing.nix
6 ../../../home-manager/profiles/drawing.nix
7 ../../../home-manager/profiles/gaming.nix
8 ../../../home-manager/profiles/gnupg.nix
9 ../../../home-manager/profiles/graphical.nix
10 ../../../home-manager/profiles/networking.nix
11 ../../../home-manager/profiles/radio.nix
12 ../../../home-manager/profiles/science.nix
13 ../../../home-manager/profiles/video.nix
14 ../../../home-manager/profiles/yt-dlp.nix
15 ../../../home-manager/profiles/mpv.nix
16 ../../../home-manager/profiles/wireless.nix
17
18 ../../../home-manager/profiles/emacs.nix
19 ../../../home-manager/profiles/firefox.nix
20 ../../../home-manager/profiles/xmonad.nix
21 ../../../home-manager/profiles/ghc.nix
22
23 ../mails.nix
24 ];
25 programs.bash.shellAliases.riseup = "sudo ip netns exec riseup sudo -u $USER PULSE_SERVER=/run/user/$(id -u $USER)/pulse/native";
26 programs.gpg.homedir = "${config.home.homeDirectory}/files/sec/.gnupg";
27 home.sessionVariables = {
28 PASSWORD_STORE_DIR = "$HOME/files/sec/.password-store";
29 };
30 home.packages = [
31 pkgs.ghostscript
32 #pkgs.go-mtpfs
33 pkgs.ntfs3g
34 pkgs.p7zip
35 pkgs.pdftk
36 pkgs.vips
37 pkgs.poppler_utils
38 # psnup conflicts with pkgs.texlive.combined.scheme-*
39 (lib.lowPrio pkgs.psutils)
40 pkgs.qpdf
41 pkgs.libreoffice
42 pkgs.calibre
43 pkgs.evince
44 pkgs.xsane
45 #pkgs.stig
46 pkgs.gthumb
47 pkgs.thunderbird
48 #pkgs.chromium
49 pkgs.fluidsynth
50 pkgs.gpsbabel
51 #(pkgs.qgis.override { extraPythonPackages = (ps: [
52 # ps.pyqt5_with_qtwebkit
53 #]); })
54 #pkgs.libva-utils
55 pkgs.pandoc
56 pkgs.texlive.combined.scheme-small
57 #pkgs.ristretto
58 pkgs.xfce.mousepad
59 #pkgs.mate.pluma
60 pkgs.wxmaxima
61 pkgs.espeak-ng
62 pkgs.iodine
63 #pkgs.qsynth
64 ];
65
66 /* Cannot be automounted
67 systemd.user.mounts = {
68 mnt-aubergine = {
69 Unit = {
70 Wants = [
71 "network-online.target"
72 "wireguard-wg-intra.target"
73 ];
74 After = [
75 "network-online.target"
76 "wireguard-wg-intra.target"
77 ];
78 };
79 Install = {
80 WantedBy = ["default.target"];
81 };
82 Mount = {
83 What = "julm@aubergine.wg:/";
84 Where = "/mnt/aubergine";
85 Type = "fuse.sshfs";
86 Options = lib.concatStringsSep "," [
87 "user"
88 "uid=julm"
89 "gid=users"
90 "allow_other"
91 "exec" # Override "user"'s noexec
92 "noatime"
93 "nosuid"
94 "noauto"
95 "dir_cache=no"
96 #"reconnect"
97 "x-gvfs-hide"
98 # Does not work for user mounts
99 #"x-systemd.automount"
100 "IdentityFile=/home/julm/.ssh/id_ed25519"
101 #"Compression=yes" # YMMV
102 # Disconnect approximately 2*15=30 seconds after a network failure
103 "ServerAliveCountMax=1"
104 "ServerAliveInterval=15"
105 ];
106 };
107 };
108 };
109 */
110 /*
111 Automounting does not work without root privileges
112 systemd.user.automounts = {
113 mnt-aubergine = {
114 Install = {
115 WantedBy = ["user.target"];
116 };
117 Unit = {
118 };
119 Automount = {
120 Where = "/mnt/aubergine";
121 TimeoutIdleSec = "5 min";
122 };
123 };
124 };
125 */
126 }