]> Git — Sourcephile - julm/julm-nix.git/blob - nixos/profiles/builder.nix
nix: use `nix.settings`
[julm/julm-nix.git] / nixos / profiles / builder.nix
1 { inputs, ... }:
2 {
3 nix.settings.experimental-features = [ "nix-command" "flakes" ];
4 #nix.registry.self.flake = inputs.self;
5 # Pin the rev to the revision of the public Nixpkgs that the system was built from.
6 # This is the version which will be locked by flakes using flake:nixpkgs
7 nix.registry.nixpkgs = {
8 from = { id = "nixpkgs"; type = "indirect"; };
9 to = {
10 owner = "NixOS";
11 repo = "nixpkgs";
12 inherit (inputs.nixpkgs) rev;
13 type = "github";
14 };
15 };
16 nix.nixPath = [
17 "nixpkgs=${inputs.nixpkgs}"
18 ];
19 }