]> Git — Sourcephile - julm/julm-nix.git/blob - nixos/profiles/builder.nix
nixos: add profile builder
[julm/julm-nix.git] / nixos / profiles / builder.nix
1 { inputs, pkgs, lib, config, ... }:
2 {
3 nix.extraOptions = ''
4 experimental-features = nix-command flakes
5 '';
6 #nix.registry.self.flake = inputs.self;
7 # Pin the rev to the revision of the public Nixpkgs that the system was built from.
8 # This is the version which will be locked by flakes using flake:nixpkgs
9 nix.registry.nixpkgs = {
10 from = { id = "nixpkgs"; type = "indirect"; };
11 to = {
12 owner = "NixOS";
13 repo = "nixpkgs";
14 rev = inputs.nixpkgs.rev;
15 type = "github";
16 };
17 };
18 nix.nixPath = [
19 "nixpkgs=${inputs.nixpkgs}"
20 ];
21 }