1 { config, pkgs, lib, ... }:
4 ../nixos/profiles/graphical.nix
5 ../nixos/profiles/lang-fr.nix
6 ../nixos/profiles/printing.nix
12 # Lower kernel's security for better performances
13 boot.kernelParams = [ "mitigations=off" ];
15 home-manager.users.sevy = {
16 imports = [ ../homes/sevy.nix ];
18 systemd.services.home-manager-sevy.postStart = ''
19 ${pkgs.nix}/bin/nix-env --delete-generations +1 --profile /nix/var/nix/profiles/per-user/sevy/home-manager
24 # Put the hashedPassword in /nix/store, but it will also be in /etc/passwd
25 # which is already world readable.
26 hashedPassword = lib.readFile patate/users/sevy/login/hashedPassword.clear;
29 config.services.davfs2.davGroup
44 #"ssh://nix-ssh@losurdo.wg?priority=30"
45 #"ssh://nix-ssh@oignon.wg?priority=10"
47 trusted-public-keys = map lib.readFile [
48 ../users/root/nix/losurdo.pub
49 ../users/root/nix/oignon.pub
54 environment.systemPackages = [
55 pkgs.riseup-vpn # Can't be installed by home-manager because it needs to install policy-kit rules
61 # NOTE: xfconf-query -c xfce4-session -p /general/LockCommand -s "physlock" --create -t string
71 defaultSession = "mate";
73 user = config.users.users.sevy.name;
78 virtualisation.virtualbox.host.enable = true;
80 # This value determines the NixOS release with which your system is to be
81 # compatible, in order to avoid breaking some software such as database
82 # servers. You should change this only after NixOS release notes say you should.
83 system.stateVersion = "20.03"; # Did you read the comment?