]> Git — Sourcephile - julm/julm-nix.git/blob - hosts/patate.nix
git: ignore formatting with nixfmt-rfc-style
[julm/julm-nix.git] / hosts / patate.nix
1 {
2 config,
3 pkgs,
4 lib,
5 ...
6 }:
7 {
8 imports = [
9 ../nixos/profiles/graphical.nix
10 ../nixos/profiles/lang-fr.nix
11 ../nixos/profiles/laptop.nix
12 ../nixos/profiles/printing.nix
13 ../nixos/profiles/home.nix
14 patate/backup.nix
15 patate/hardware.nix
16 patate/nebula.nix
17 patate/networking.nix
18 ];
19
20 # Lower kernel's security for better performances
21 security.kernel.mitigations = "off";
22
23 home-manager.users.sevy = {
24 imports = [ ../homes/sevy.nix ];
25 };
26 users.users.sevy = {
27 isNormalUser = true;
28 uid = 1000;
29 # Put the hashedPassword in /nix/store, but it will also be in /etc/passwd
30 # which is already world readable.
31 hashedPassword = lib.readFile patate/users/sevy/login/hashedPassword.clear;
32 extraGroups = [
33 "adbusers"
34 config.services.davfs2.davGroup
35 "lp"
36 "networkmanager"
37 "scanner"
38 "systemd-journal"
39 "tor"
40 "vboxusers"
41 "video"
42 "wheel"
43 ];
44 };
45
46 nix = {
47 settings = {
48 substituters = [
49 #"ssh://nix-ssh@losurdo.wg?priority=30"
50 #"ssh://nix-ssh@oignon.wg?priority=10"
51 ];
52 trusted-public-keys = map lib.readFile [
53 ../users/root/nix/losurdo.pub
54 ../users/root/nix/oignon.pub
55 ];
56 };
57 };
58
59 environment.systemPackages = [
60 pkgs.riseup-vpn # Can't be installed by home-manager because it needs to install policy-kit rules
61 ];
62
63 services.xserver = {
64 desktopManager = {
65 mate.enable = true;
66 xfce.enable = true;
67 xterm.enable = false;
68 };
69 };
70
71 services.displayManager = {
72 defaultSession = "mate";
73 autoLogin = {
74 user = config.users.users.sevy.name;
75 };
76 };
77
78 virtualisation.virtualbox.host.enable = true;
79
80 # This value determines the NixOS release with which your system is to be
81 # compatible, in order to avoid breaking some software such as database
82 # servers. You should change this only after NixOS release notes say you should.
83 system.stateVersion = "20.03"; # Did you read the comment?
84 }