1 { config, pkgs, lib, ... }:
4 ../nixos/profiles/dnscrypt-proxy2.nix
5 ../nixos/profiles/graphical.nix
6 ../nixos/profiles/lang-fr.nix
7 ../nixos/profiles/printing.nix
8 ../nixos/profiles/wireguard/wg-intra.nix
14 # Lower kernel's security for better performances
15 boot.kernelParams = [ "mitigations=off" ];
17 home-manager.users.sevy = {
18 imports = [ ../homes/sevy.nix ];
20 systemd.services.home-manager-sevy.postStart = ''
21 ${pkgs.nix}/bin/nix-env --delete-generations +1 --profile /nix/var/nix/profiles/per-user/sevy/home-manager
26 # Put the hashedPassword in /nix/store, but it will also be in /etc/passwd
27 # which is already world readable.
28 hashedPassword = lib.readFile patate/users/sevy/login/hashedPassword.clear;
31 config.services.davfs2.davGroup
45 trusted-users = [ config.users.users."sevy".name ];
47 #"ssh://nix-ssh@losurdo.wg?priority=30"
48 #"ssh://nix-ssh@oignon.wg?priority=10"
50 trusted-public-keys = map lib.readFile [
51 ../users/root/nix/losurdo.pub
52 ../users/root/nix/oignon.pub
56 install.substituteOnDestination = false;
58 environment.systemPackages = [
59 pkgs.riseup-vpn # Can't be installed by home-manager because it needs to install policy-kit rules
65 # NOTE: xfconf-query -c xfce4-session -p /general/LockCommand -s "physlock" --create -t string
75 defaultSession = "mate";
77 user = config.users.users.sevy.name;
82 virtualisation.virtualbox.host.enable = true;
84 # This value determines the NixOS release with which your system is to be
85 # compatible, in order to avoid breaking some software such as database
86 # servers. You should change this only after NixOS release notes say you should.
87 system.stateVersion = "20.03"; # Did you read the comment?