]> Git — Sourcephile - julm/julm-nix.git/blob - homes/julm/hosts/oignon.nix
oignon: sshfs: user mounts cannot be automounted
[julm/julm-nix.git] / homes / julm / hosts / oignon.nix
1 { pkgs, lib, config, ... }:
2 {
3 imports = [
4 ../../../home-manager/profiles/chat.nix
5 ../../../home-manager/profiles/developing.nix
6 ../../../home-manager/profiles/drawing.nix
7 ../../../home-manager/profiles/gaming.nix
8 ../../../home-manager/profiles/gnupg.nix
9 ../../../home-manager/profiles/graphical.nix
10 ../../../home-manager/profiles/networking.nix
11 ../../../home-manager/profiles/office.nix
12 ../../../home-manager/profiles/science.nix
13 ../../../home-manager/profiles/sharing.nix
14 ../../../home-manager/profiles/video.nix
15 ../../../home-manager/profiles/wireless.nix
16
17 ../../../home-manager/profiles/emacs.nix
18 ../../../home-manager/profiles/firefox.nix
19 ../../../home-manager/profiles/xmonad.nix
20 ../../../home-manager/profiles/ghc.nix
21
22 ../mails.nix
23 ];
24 programs.bash.shellAliases.riseup = "sudo ip netns exec riseup sudo -u $USER PULSE_SERVER=/run/user/$(id -u $USER)/pulse/native";
25 programs.gpg.homedir = "${config.home.homeDirectory}/files/sec/.gnupg";
26 home.sessionVariables = {
27 PASSWORD_STORE_DIR = "$HOME/files/sec/.password-store";
28 };
29 home.packages = [
30 #pkgs.chromium
31 pkgs.fluidsynth
32 pkgs.gpsbabel
33 #(pkgs.qgis.override { extraPythonPackages = (ps: [
34 # ps.pyqt5_with_qtwebkit
35 #]); })
36 #pkgs.libva-utils
37 #pkgs.ristretto
38 pkgs.xfce.mousepad
39 #pkgs.mate.pluma
40 pkgs.wxmaxima
41 pkgs.espeak-ng
42 pkgs.iodine
43 #pkgs.qsynth
44 ];
45
46 /* Cannot be automounted
47 systemd.user.mounts = {
48 mnt-aubergine = {
49 Unit = {
50 Wants = [
51 "network-online.target"
52 "wireguard-wg-intra.target"
53 ];
54 After = [
55 "network-online.target"
56 "wireguard-wg-intra.target"
57 ];
58 };
59 Install = {
60 WantedBy = ["default.target"];
61 };
62 Mount = {
63 What = "julm@aubergine.wg:/";
64 Where = "/mnt/aubergine";
65 Type = "fuse.sshfs";
66 Options = lib.concatStringsSep "," [
67 "user"
68 "uid=julm"
69 "gid=users"
70 "allow_other"
71 "exec" # Override "user"'s noexec
72 "noatime"
73 "nosuid"
74 "noauto"
75 "dir_cache=no"
76 #"reconnect"
77 "x-gvfs-hide"
78 # Does not work for user mounts
79 #"x-systemd.automount"
80 "IdentityFile=/home/julm/.ssh/id_ed25519"
81 #"Compression=yes" # YMMV
82 # Disconnect approximately 2*15=30 seconds after a network failure
83 "ServerAliveCountMax=1"
84 "ServerAliveInterval=15"
85 ];
86 };
87 };
88 };
89 */
90 /*
91 Automounting does not work without root privileges
92 systemd.user.automounts = {
93 mnt-aubergine = {
94 Install = {
95 WantedBy = ["user.target"];
96 };
97 Unit = {
98 };
99 Automount = {
100 Where = "/mnt/aubergine";
101 TimeoutIdleSec = "5 min";
102 };
103 };
104 };
105 */
106 }