]> Git — Sourcephile - julm/julm-nix.git/blob - homes/julm/hosts/oignon.nix
oignon: rtl-sdr: add support
[julm/julm-nix.git] / homes / julm / hosts / oignon.nix
1 { pkgs, lib, config, ... }:
2 {
3 imports = [
4 ../../../home-manager/profiles/chat.nix
5 ../../../home-manager/profiles/developing.nix
6 ../../../home-manager/profiles/drawing.nix
7 ../../../home-manager/profiles/gaming.nix
8 ../../../home-manager/profiles/gnupg.nix
9 ../../../home-manager/profiles/graphical.nix
10 ../../../home-manager/profiles/networking.nix
11 ../../../home-manager/profiles/office.nix
12 ../../../home-manager/profiles/radio.nix
13 ../../../home-manager/profiles/science.nix
14 ../../../home-manager/profiles/sharing.nix
15 ../../../home-manager/profiles/video.nix
16 ../../../home-manager/profiles/wireless.nix
17
18 ../../../home-manager/profiles/emacs.nix
19 ../../../home-manager/profiles/firefox.nix
20 ../../../home-manager/profiles/xmonad.nix
21 ../../../home-manager/profiles/ghc.nix
22
23 ../mails.nix
24 ];
25 programs.bash.shellAliases.riseup = "sudo ip netns exec riseup sudo -u $USER PULSE_SERVER=/run/user/$(id -u $USER)/pulse/native";
26 programs.gpg.homedir = "${config.home.homeDirectory}/files/sec/.gnupg";
27 home.sessionVariables = {
28 PASSWORD_STORE_DIR = "$HOME/files/sec/.password-store";
29 };
30 home.packages = [
31 #pkgs.chromium
32 pkgs.fluidsynth
33 pkgs.gpsbabel
34 #(pkgs.qgis.override { extraPythonPackages = (ps: [
35 # ps.pyqt5_with_qtwebkit
36 #]); })
37 #pkgs.libva-utils
38 #pkgs.ristretto
39 pkgs.xfce.mousepad
40 #pkgs.mate.pluma
41 pkgs.wxmaxima
42 pkgs.espeak-ng
43 pkgs.iodine
44 #pkgs.qsynth
45 ];
46
47 /* Cannot be automounted
48 systemd.user.mounts = {
49 mnt-aubergine = {
50 Unit = {
51 Wants = [
52 "network-online.target"
53 "wireguard-wg-intra.target"
54 ];
55 After = [
56 "network-online.target"
57 "wireguard-wg-intra.target"
58 ];
59 };
60 Install = {
61 WantedBy = ["default.target"];
62 };
63 Mount = {
64 What = "julm@aubergine.wg:/";
65 Where = "/mnt/aubergine";
66 Type = "fuse.sshfs";
67 Options = lib.concatStringsSep "," [
68 "user"
69 "uid=julm"
70 "gid=users"
71 "allow_other"
72 "exec" # Override "user"'s noexec
73 "noatime"
74 "nosuid"
75 "noauto"
76 "dir_cache=no"
77 #"reconnect"
78 "x-gvfs-hide"
79 # Does not work for user mounts
80 #"x-systemd.automount"
81 "IdentityFile=/home/julm/.ssh/id_ed25519"
82 #"Compression=yes" # YMMV
83 # Disconnect approximately 2*15=30 seconds after a network failure
84 "ServerAliveCountMax=1"
85 "ServerAliveInterval=15"
86 ];
87 };
88 };
89 };
90 */
91 /*
92 Automounting does not work without root privileges
93 systemd.user.automounts = {
94 mnt-aubergine = {
95 Install = {
96 WantedBy = ["user.target"];
97 };
98 Unit = {
99 };
100 Automount = {
101 Where = "/mnt/aubergine";
102 TimeoutIdleSec = "5 min";
103 };
104 };
105 };
106 */
107 }