1 { config, pkgs, lib, inputs, hostName, ... }:
4 ../nixos/profiles/dnscrypt-proxy2.nix
5 ../nixos/profiles/security.nix
6 ../nixos/profiles/wireguard/wg-intra.nix
11 home-manager.users.sevy = {
12 imports = [ ../homes/sevy.nix ];
13 host.hardware = ["ThinkPad" "X200"];
15 systemd.services.home-manager-sevy.postStart = ''
16 ${pkgs.nix}/bin/nix-env --delete-generations +1 --profile /nix/var/nix/profiles/per-user/sevy/home-manager
18 security.lockKernelModules = false;
19 users.mutableUsers = false;
23 # Put the hashedPassword in /nix/store, but it will also be in /etc/passwd
24 # which is already world readable.
25 hashedPassword = lib.readFile ../private/world/sevy/hashedPassword;
28 config.services.davfs2.davGroup
43 autoOptimiseStore = true;
46 gc.options = "--delete-older-than 7d";
47 nixPath = lib.mkForce [ ];
48 trustedUsers = [ users.sevy.name ];
50 "http://nix-localcache.losurdo.wg"
51 "ssh://nix-ssh@oignon.wg"
53 binaryCachePublicKeys = [
54 "losurdo.sourcephile.fr-1:XGeaIE2AA2mZskSZ5bIDrfx53q+TDDWJOUEpZDX7los="
55 "oignon.sourcephile.fr:slxL7XLsGXlD1r6gvw1imL5uQntW0TTlQgGQt3LBJgQ="
58 services.openssh.passwordAuthentication = false;
60 environment.systemPackages = [
64 documentation.nixos.enable = true;
65 time.timeZone = "Europe/Paris";
66 i18n.defaultLocale = "fr_FR.UTF-8";
67 console.font = "Lat2-Terminus16";
68 console.keyMap = "fr";
72 domain = "localdomain";
79 #backend = "wpa_supplicant";
87 51413 # transmission-gtk
91 51413 # transmission-gtk
99 hardware.pulseaudio.enable = true;
100 hardware.sane.enable = true;
101 hardware.sane.extraBackends = [ pkgs.hplipWithPlugin ];
103 environment.variables = {
106 SYSTEMD_LESS = "FKMRX";
111 interactiveShellInit = ''
112 bind '"\e[A":history-search-backward'
113 bind '"\e[B":history-search-forward'
115 # Ignore duplicate commands, ignore commands starting with a space
116 export HISTCONTROL=erasedups:ignorespace
117 export HISTSIZE=42000
118 # Append to the history instead of overwriting (good for multiple connections)
122 mkcd () { mkdir -p "$1"; cd "$1"; }
125 then sudo tee /proc/acpi/ibm/fan <<<"level $1"
126 else grep '^\(level\|speed\):' /proc/acpi/ibm/fan
133 grep = "grep --color";
136 ls = "ls --color=tty";
137 mem = "ps -e -orss=,user=,args= | sort -b -k1,1n";
140 st="sudo systemctl status";
141 u="systemctl --user";
142 j="sudo journalctl -u";
143 jb="sudo journalctl -b";
145 nix-history="sudo nix-env --list-generations --profile /nix/var/nix/profiles/system";
147 sshfs = "sshfs -o ServerAliveInterval=15 -o reconnect -f";
157 openFirewall = false;
167 fileSystems."/home/sevy/mnt/ilico/severine" = {
168 device = "https://nuage.ilico.org/remote.php/dav/files/severine/";
171 let conf = pkgs.writeText "davfs2.conf" ''
172 backup_dir /home/sevy/Documents/EnTransfert/ilico/severine
173 cache_dir /home/sevy/.cache/davfs2/ilico/severine
175 [ "conf=${conf}" "user" "noexec" "nosuid" "noauto" ]; # "x-systemd.automount"
178 packages = [ pkgs.gnome3.dconf ];
183 services.journald = {
186 MaxRetentionSec=1month
191 services.physlock = {
194 # NOTE: xfconf-query -c xfce4-session -p /general/LockCommand -s "physlock" --create -t string
196 services.printing = {
205 # Allow members of the "adbusers" group to mount Android devices via MTP
206 pkgs.android-udev-rules
212 xkbOptions = "eurosign:e";
213 libinput.enable = true;
218 #pkgs.xfce.thunar-archive-plugin
221 xterm.enable = false;
224 defaultSession = "xfce";
227 user = config.users.users.sevy.name;
232 virtualisation.virtualbox.host.enable = true;
234 # This value determines the NixOS release with which your system is to be
235 # compatible, in order to avoid breaking some software such as database
236 # servers. You should change this only after NixOS release notes say you should.
237 system.stateVersion = "20.03"; # Did you read the comment?