1 { config, pkgs, lib, ... }:
4 ../nixos/profiles/graphical.nix
5 ../nixos/profiles/lang-fr.nix
6 ../nixos/profiles/laptop.nix
7 ../nixos/profiles/printing.nix
14 # Lower kernel's security for better performances
15 security.kernel.mitigations = "off";
17 home-manager.users.sevy = {
18 imports = [ ../homes/sevy.nix ];
23 # Put the hashedPassword in /nix/store, but it will also be in /etc/passwd
24 # which is already world readable.
25 hashedPassword = lib.readFile patate/users/sevy/login/hashedPassword.clear;
28 config.services.davfs2.davGroup
43 #"ssh://nix-ssh@losurdo.wg?priority=30"
44 #"ssh://nix-ssh@oignon.wg?priority=10"
46 trusted-public-keys = map lib.readFile [
47 ../users/root/nix/losurdo.pub
48 ../users/root/nix/oignon.pub
53 environment.systemPackages = [
54 pkgs.riseup-vpn # Can't be installed by home-manager because it needs to install policy-kit rules
65 services.displayManager = {
66 defaultSession = "mate";
68 user = config.users.users.sevy.name;
72 virtualisation.virtualbox.host.enable = true;
74 # This value determines the NixOS release with which your system is to be
75 # compatible, in order to avoid breaking some software such as database
76 # servers. You should change this only after NixOS release notes say you should.
77 system.stateVersion = "20.03"; # Did you read the comment?