]> Git — Sourcephile - julm/julm-nix.git/blob - homes/julm/hosts/oignon.nix
julm: oignon: frozen-bubble: install
[julm/julm-nix.git] / homes / julm / hosts / oignon.nix
1 { pkgs, lib, config, ... }:
2 {
3 imports = [
4 ../../../home-manager/profiles/chat.nix
5 ../../../home-manager/profiles/developing.nix
6 ../../../home-manager/profiles/drawing.nix
7 ../../../home-manager/profiles/gaming.nix
8 ../../../home-manager/profiles/gnupg.nix
9 ../../../home-manager/profiles/graphical.nix
10 ../../../home-manager/profiles/networking.nix
11 ../../../home-manager/profiles/radio.nix
12 ../../../home-manager/profiles/science.nix
13 ../../../home-manager/profiles/video.nix
14 ../../../home-manager/profiles/yt-dlp.nix
15 ../../../home-manager/profiles/mpv.nix
16 ../../../home-manager/profiles/wireless.nix
17
18 ../../../home-manager/profiles/emacs.nix
19 ../../../home-manager/profiles/firefox.nix
20 ../../../home-manager/profiles/xmonad.nix
21 ../../../home-manager/profiles/ghc.nix
22
23 ../mails.nix
24 ];
25 programs.bash.shellAliases.riseup = "sudo ip netns exec riseup sudo -u $USER PULSE_SERVER=/run/user/$(id -u $USER)/pulse/native";
26 programs.gpg.homedir = "${config.home.homeDirectory}/files/sec/.gnupg";
27 home.sessionVariables = {
28 PASSWORD_STORE_DIR = "$HOME/files/sec/.password-store";
29 };
30 home.packages = [
31 pkgs.ghostscript
32 #pkgs.go-mtpfs
33 pkgs.ntfs3g
34 pkgs.p7zip
35 pkgs.unar
36 pkgs.pdftk
37 pkgs.vips
38 pkgs.poppler_utils
39 # psnup conflicts with pkgs.texlive.combined.scheme-*
40 (lib.lowPrio pkgs.psutils)
41 pkgs.ink
42 pkgs.djview
43 pkgs.qpdf
44 pkgs.libreoffice
45 pkgs.calibre
46 pkgs.zotero
47 pkgs.evince
48 pkgs.marble
49 pkgs.gcompris
50 pkgs.frozen-bubble
51 #pkgs.neverball
52 pkgs.xsane
53 pkgs.stig
54 pkgs.gthumb
55 pkgs.thunderbird
56 #pkgs.chromium
57 pkgs.fluidsynth
58 pkgs.gpsbabel
59 #(pkgs.qgis.override { extraPythonPackages = (ps: [
60 # ps.pyqt5_with_qtwebkit
61 #]); })
62 #pkgs.libva-utils
63 pkgs.otpclient
64 pkgs.pandoc
65 pkgs.pdf2djvu
66 #pkgs.ristretto
67 pkgs.xfce.mousepad
68 #pkgs.mate.pluma
69 pkgs.wxmaxima
70 pkgs.espeak-ng
71 pkgs.iodine
72 #pkgs.qsynth
73 ];
74
75 /* Cannot be automounted
76 systemd.user.mounts = {
77 mnt-aubergine = {
78 Unit = {
79 Wants = [
80 "network-online.target"
81 "wireguard-wg-intra.target"
82 ];
83 After = [
84 "network-online.target"
85 "wireguard-wg-intra.target"
86 ];
87 };
88 Install = {
89 WantedBy = ["default.target"];
90 };
91 Mount = {
92 What = "julm@aubergine.wg:/";
93 Where = "/mnt/aubergine";
94 Type = "fuse.sshfs";
95 Options = lib.concatStringsSep "," [
96 "user"
97 "uid=julm"
98 "gid=users"
99 "allow_other"
100 "exec" # Override "user"'s noexec
101 "noatime"
102 "nosuid"
103 "noauto"
104 "dir_cache=no"
105 #"reconnect"
106 "x-gvfs-hide"
107 # Does not work for user mounts
108 #"x-systemd.automount"
109 "IdentityFile=/home/julm/.ssh/id_ed25519"
110 #"Compression=yes" # YMMV
111 # Disconnect approximately 2*15=30 seconds after a network failure
112 "ServerAliveCountMax=1"
113 "ServerAliveInterval=15"
114 ];
115 };
116 };
117 };
118 */
119 /*
120 Automounting does not work without root privileges
121 systemd.user.automounts = {
122 mnt-aubergine = {
123 Install = {
124 WantedBy = ["user.target"];
125 };
126 Unit = {
127 };
128 Automount = {
129 Where = "/mnt/aubergine";
130 TimeoutIdleSec = "5 min";
131 };
132 };
133 };
134 */
135 }