1 { config, pkgs, lib, ... }:
4 ../nixos/profiles/graphical.nix
5 ../nixos/profiles/lang-fr.nix
6 ../nixos/profiles/printing.nix
12 # Lower kernel's security for better performances
13 boot.kernelParams = [ "mitigations=off" ];
15 home-manager.users.sevy = {
16 imports = [ ../homes/sevy.nix ];
21 # Put the hashedPassword in /nix/store, but it will also be in /etc/passwd
22 # which is already world readable.
23 hashedPassword = lib.readFile patate/users/sevy/login/hashedPassword.clear;
26 config.services.davfs2.davGroup
41 #"ssh://nix-ssh@losurdo.wg?priority=30"
42 #"ssh://nix-ssh@oignon.wg?priority=10"
44 trusted-public-keys = map lib.readFile [
45 ../users/root/nix/losurdo.pub
46 ../users/root/nix/oignon.pub
51 environment.systemPackages = [
52 pkgs.riseup-vpn # Can't be installed by home-manager because it needs to install policy-kit rules
62 defaultSession = "mate";
64 user = config.users.users.sevy.name;
69 virtualisation.virtualbox.host.enable = true;
71 # This value determines the NixOS release with which your system is to be
72 # compatible, in order to avoid breaking some software such as database
73 # servers. You should change this only after NixOS release notes say you should.
74 system.stateVersion = "20.03"; # Did you read the comment?