1 { config, pkgs, lib, inputs, hostName, ... }:
2 let inherit (config.users) users; in
5 ../profiles/dnscrypt-proxy2.nix
10 home-manager.users.sevy = {
11 imports = [ ../homes/sevy.nix ];
13 host.hardware = ["ThinkPad" "X200"];
15 systemd.services.home-manager-julm.postStart = ''
16 ${pkgs.nix}/bin/nix-env --delete-generations +1 --profile /nix/var/nix/profiles/per-user/sevy/home-manager
18 users.mutableUsers = false;
22 # Put the hashedPassword in /nix/store, but it will also be in /etc/passwd
23 # which is already world readable.
24 hashedPassword = lib.readFile ../private/world/sevy/hashedPassword;
40 auto-optimise-store = true
45 options = "--delete-older-than 7d";
48 "nixpkgs=/etc/nixpkgs"
49 "nixpkgs-overlays=/etc/nixpkgs-overlays/overlays.nix"
51 trustedUsers = [ users.sevy.name ];
53 "https://nix-localcache.sourcephile.fr"
54 "ssh://nix-ssh@192.168.0.115" # FIXME: use wireguard
56 binaryCachePublicKeys = [
57 "losurdo.sourcephile.fr-1:XGeaIE2AA2mZskSZ5bIDrfx53q+TDDWJOUEpZDX7los="
58 "oignon.sourcephile.fr:slxL7XLsGXlD1r6gvw1imL5uQntW0TTlQgGQt3LBJgQ="
61 services.openssh.passwordAuthentication = false;
66 environment.etc."nixpkgs".source = pkgs.path;
67 environment.etc."nixpkgs-overlays".source = inputs.self + "/nixpkgs";
69 documentation.nixos.enable = true;
70 time.timeZone = "Europe/Paris";
71 i18n.defaultLocale = "fr_FR.UTF-8";
72 console.font = "Lat2-Terminus16";
73 console.keyMap = "fr";
77 domain = "localdomain";
84 #backend = "wpa_supplicant";
92 51413 # transmission-gtk
96 51413 # transmission-gtk
104 hardware.pulseaudio.enable = true;
105 hardware.sane.enable = true;
106 hardware.sane.extraBackends = [ pkgs.hplipWithPlugin ];
108 environment.variables = {
111 SYSTEMD_LESS = "FKMRX";
116 interactiveShellInit = ''
117 bind '"\e[A":history-search-backward'
118 bind '"\e[B":history-search-forward'
120 # Ignore duplicate commands, ignore commands starting with a space
121 export HISTCONTROL=erasedups:ignorespace
122 export HISTSIZE=42000
123 # Append to the history instead of overwriting (good for multiple connections)
127 mkcd () { mkdir -p "$1"; cd "$1"; }
130 then sudo tee /proc/acpi/ibm/fan <<<"level $1"
131 else grep '^\(level\|speed\):' /proc/acpi/ibm/fan
138 grep = "grep --color";
141 ls = "ls --color=tty";
142 mem = "ps -e -orss=,user=,args= | sort -b -k1,1n";
145 st="sudo systemctl status";
146 u="systemctl --user";
147 j="sudo journalctl -u";
148 jb="sudo journalctl -b";
150 nix-history="sudo nix-env --list-generations --profile /nix/var/nix/profiles/system";
152 sshfs = "sshfs -o ServerAliveInterval=15 -o reconnect -f";
163 openFirewall = false;
169 packages = [ pkgs.gnome3.dconf ];
177 MaxRetentionSec=1month
185 # NOTE: xfconf-query -c xfce4-session -p /general/LockCommand -s "physlock" --create -t string
196 # Allow members of the "adbusers" group to mount Android devices via MTP
197 pkgs.android-udev-rules
203 xkbOptions = "eurosign:e";
204 libinput.enable = true;
209 #pkgs.xfce.thunar-archive-plugin
212 xterm.enable = false;
215 defaultSession = "xfce";
218 user = users.sevy.name;
224 virtualisation.virtualbox.host.enable = true;
226 # This value determines the NixOS release with which your system is to be
227 # compatible, in order to avoid breaking some software such as database
228 # servers. You should change this only after NixOS release notes say you should.
229 system.stateVersion = "20.03"; # Did you read the comment?