1 { config, pkgs, lib, inputs, hostName, ... }:
2 let inherit (config.users) users; in
5 ../profiles/dnscrypt-proxy2.nix
6 ../profiles/security.nix
7 ../networking/wireguard/wg-intra.nix
12 home-manager.users.sevy = {
13 imports = [ ../homes/sevy.nix ];
14 host.hardware = ["ThinkPad" "X200"];
16 systemd.services.home-manager-julm.postStart = ''
17 ${pkgs.nix}/bin/nix-env --delete-generations +1 --profile /nix/var/nix/profiles/per-user/sevy/home-manager
19 security.lockKernelModules = false;
20 users.mutableUsers = false;
24 # Put the hashedPassword in /nix/store, but it will also be in /etc/passwd
25 # which is already world readable.
26 hashedPassword = lib.readFile ../private/world/sevy/hashedPassword;
29 config.services.davfs2.davGroup
44 autoOptimiseStore = true;
48 options = "--delete-older-than 7d";
51 "nixpkgs=/etc/nixpkgs"
52 "nixpkgs-overlays=/etc/nixpkgs-overlays/overlays.nix"
54 trustedUsers = [ users.sevy.name ];
56 "http://nix-localcache.losurdo.wg"
57 "ssh://nix-ssh@oignon.wg"
59 binaryCachePublicKeys = [
60 "losurdo.sourcephile.fr-1:XGeaIE2AA2mZskSZ5bIDrfx53q+TDDWJOUEpZDX7los="
61 "oignon.sourcephile.fr:slxL7XLsGXlD1r6gvw1imL5uQntW0TTlQgGQt3LBJgQ="
64 services.openssh.passwordAuthentication = false;
69 environment.etc."nixpkgs".source = pkgs.path;
70 environment.etc."nixpkgs-overlays".source = inputs.self + "/nixpkgs";
71 environment.systemPackages = [
75 documentation.nixos.enable = true;
76 time.timeZone = "Europe/Paris";
77 i18n.defaultLocale = "fr_FR.UTF-8";
78 console.font = "Lat2-Terminus16";
79 console.keyMap = "fr";
83 domain = "localdomain";
90 #backend = "wpa_supplicant";
98 51413 # transmission-gtk
102 51413 # transmission-gtk
110 hardware.pulseaudio.enable = true;
111 hardware.sane.enable = true;
112 hardware.sane.extraBackends = [ pkgs.hplipWithPlugin ];
114 environment.variables = {
117 SYSTEMD_LESS = "FKMRX";
122 interactiveShellInit = ''
123 bind '"\e[A":history-search-backward'
124 bind '"\e[B":history-search-forward'
126 # Ignore duplicate commands, ignore commands starting with a space
127 export HISTCONTROL=erasedups:ignorespace
128 export HISTSIZE=42000
129 # Append to the history instead of overwriting (good for multiple connections)
133 mkcd () { mkdir -p "$1"; cd "$1"; }
136 then sudo tee /proc/acpi/ibm/fan <<<"level $1"
137 else grep '^\(level\|speed\):' /proc/acpi/ibm/fan
144 grep = "grep --color";
147 ls = "ls --color=tty";
148 mem = "ps -e -orss=,user=,args= | sort -b -k1,1n";
151 st="sudo systemctl status";
152 u="systemctl --user";
153 j="sudo journalctl -u";
154 jb="sudo journalctl -b";
156 nix-history="sudo nix-env --list-generations --profile /nix/var/nix/profiles/system";
158 sshfs = "sshfs -o ServerAliveInterval=15 -o reconnect -f";
168 openFirewall = false;
178 fileSystems."/home/sevy/mnt/ilico/severine" = {
179 device = "https://nuage.ilico.org/remote.php/dav/files/severine/";
182 let conf = pkgs.writeText "davfs2.conf" ''
183 backup_dir /home/sevy/Documents/EnTransfert/ilico/severine
184 cache_dir /home/sevy/.cache/davfs2/ilico/severine
186 [ "conf=${conf}" "user" "noexec" "nosuid" "noauto" ]; # "x-systemd.automount"
189 packages = [ pkgs.gnome3.dconf ];
194 services.journald = {
197 MaxRetentionSec=1month
202 services.physlock = {
205 # NOTE: xfconf-query -c xfce4-session -p /general/LockCommand -s "physlock" --create -t string
207 services.printing = {
216 # Allow members of the "adbusers" group to mount Android devices via MTP
217 pkgs.android-udev-rules
223 xkbOptions = "eurosign:e";
224 libinput.enable = true;
229 #pkgs.xfce.thunar-archive-plugin
232 xterm.enable = false;
235 defaultSession = "xfce";
238 user = users.sevy.name;
243 virtualisation.virtualbox.host.enable = true;
245 # This value determines the NixOS release with which your system is to be
246 # compatible, in order to avoid breaking some software such as database
247 # servers. You should change this only after NixOS release notes say you should.
248 system.stateVersion = "20.03"; # Did you read the comment?