]> Git — Sourcephile - julm/julm-nix.git/blob - hosts/patate.nix
home-manager: add delete-generations
[julm/julm-nix.git] / hosts / patate.nix
1 { config, pkgs, lib, ... }:
2 {
3 imports = [
4 ../nixos/profiles/graphical.nix
5 ../nixos/profiles/lang-fr.nix
6 ../nixos/profiles/printing.nix
7 patate/backup.nix
8 patate/hardware.nix
9 patate/networking.nix
10 ];
11
12 # Lower kernel's security for better performances
13 boot.kernelParams = [ "mitigations=off" ];
14
15 home-manager.users.sevy = {
16 imports = [ ../homes/sevy.nix ];
17 };
18 users.users.sevy = {
19 isNormalUser = true;
20 uid = 1000;
21 # Put the hashedPassword in /nix/store, but it will also be in /etc/passwd
22 # which is already world readable.
23 hashedPassword = lib.readFile patate/users/sevy/login/hashedPassword.clear;
24 extraGroups = [
25 "adbusers"
26 config.services.davfs2.davGroup
27 "lp"
28 "networkmanager"
29 "scanner"
30 "systemd-journal"
31 "tor"
32 "vboxusers"
33 "video"
34 "wheel"
35 ];
36 };
37
38 nix = {
39 settings = {
40 substituters = [
41 #"ssh://nix-ssh@losurdo.wg?priority=30"
42 #"ssh://nix-ssh@oignon.wg?priority=10"
43 ];
44 trusted-public-keys = map lib.readFile [
45 ../users/root/nix/losurdo.pub
46 ../users/root/nix/oignon.pub
47 ];
48 };
49 };
50
51 environment.systemPackages = [
52 pkgs.riseup-vpn # Can't be installed by home-manager because it needs to install policy-kit rules
53 ];
54
55 services.physlock = {
56 enable = true;
57 allowAnyUser = true;
58 # NOTE: xfconf-query -c xfce4-session -p /general/LockCommand -s "physlock" --create -t string
59 };
60
61 services.xserver = {
62 desktopManager = {
63 mate.enable = true;
64 xfce.enable = true;
65 xterm.enable = false;
66 };
67 displayManager = {
68 defaultSession = "mate";
69 autoLogin = {
70 user = config.users.users.sevy.name;
71 };
72 };
73 };
74
75 virtualisation.virtualbox.host.enable = true;
76
77 # This value determines the NixOS release with which your system is to be
78 # compatible, in order to avoid breaking some software such as database
79 # servers. You should change this only after NixOS release notes say you should.
80 system.stateVersion = "20.03"; # Did you read the comment?
81 }