1 { config, pkgs, lib, inputs, hostName, ... }:
2 let inherit (config.users) users; in
5 ../profiles/dnscrypt-proxy2.nix
6 ../profiles/security.nix
7 ../networking/wireguard/wg-intra.nix
12 home-manager.users.sevy = {
13 imports = [ ../homes/sevy.nix ];
14 host.hardware = ["ThinkPad" "X200"];
16 systemd.services.home-manager-julm.postStart = ''
17 ${pkgs.nix}/bin/nix-env --delete-generations +1 --profile /nix/var/nix/profiles/per-user/sevy/home-manager
19 security.lockKernelModules = false;
20 users.mutableUsers = false;
24 # Put the hashedPassword in /nix/store, but it will also be in /etc/passwd
25 # which is already world readable.
26 hashedPassword = lib.readFile ../private/world/sevy/hashedPassword;
29 config.services.davfs2.davGroup
44 autoOptimiseStore = true;
48 options = "--delete-older-than 7d";
51 "nixpkgs=/etc/nixpkgs"
52 "nixpkgs-overlays=/etc/nixpkgs-overlays/overlays.nix"
54 trustedUsers = [ users.sevy.name ];
56 "http://nix-localcache.losurdo.wg"
57 "ssh://nix-ssh@oignon.wg"
59 binaryCachePublicKeys = [
60 "losurdo.sourcephile.fr-1:XGeaIE2AA2mZskSZ5bIDrfx53q+TDDWJOUEpZDX7los="
61 "oignon.sourcephile.fr:slxL7XLsGXlD1r6gvw1imL5uQntW0TTlQgGQt3LBJgQ="
64 services.openssh.passwordAuthentication = false;
69 environment.etc."nixpkgs".source = pkgs.path;
70 environment.etc."nixpkgs-overlays".source = inputs.self + "/nixpkgs";
72 documentation.nixos.enable = true;
73 time.timeZone = "Europe/Paris";
74 i18n.defaultLocale = "fr_FR.UTF-8";
75 console.font = "Lat2-Terminus16";
76 console.keyMap = "fr";
80 domain = "localdomain";
87 #backend = "wpa_supplicant";
95 51413 # transmission-gtk
99 51413 # transmission-gtk
107 hardware.pulseaudio.enable = true;
108 hardware.sane.enable = true;
109 hardware.sane.extraBackends = [ pkgs.hplipWithPlugin ];
111 environment.variables = {
114 SYSTEMD_LESS = "FKMRX";
119 interactiveShellInit = ''
120 bind '"\e[A":history-search-backward'
121 bind '"\e[B":history-search-forward'
123 # Ignore duplicate commands, ignore commands starting with a space
124 export HISTCONTROL=erasedups:ignorespace
125 export HISTSIZE=42000
126 # Append to the history instead of overwriting (good for multiple connections)
130 mkcd () { mkdir -p "$1"; cd "$1"; }
133 then sudo tee /proc/acpi/ibm/fan <<<"level $1"
134 else grep '^\(level\|speed\):' /proc/acpi/ibm/fan
141 grep = "grep --color";
144 ls = "ls --color=tty";
145 mem = "ps -e -orss=,user=,args= | sort -b -k1,1n";
148 st="sudo systemctl status";
149 u="systemctl --user";
150 j="sudo journalctl -u";
151 jb="sudo journalctl -b";
153 nix-history="sudo nix-env --list-generations --profile /nix/var/nix/profiles/system";
155 sshfs = "sshfs -o ServerAliveInterval=15 -o reconnect -f";
165 openFirewall = false;
175 fileSystems."/home/sevy/mnt/ilico/severine" = {
176 device = "https://nuage.ilico.org/remote.php/dav/files/severine/";
179 let conf = pkgs.writeText "davfs2.conf" ''
180 backup_dir /home/sevy/Documents/EnTransfert/ilico/severine
181 cache_dir /home/sevy/.cache/davfs2/ilico/severine
183 [ "conf=${conf}" "user" "noexec" "nosuid" "noauto" ]; # "x-systemd.automount"
186 packages = [ pkgs.gnome3.dconf ];
191 services.journald = {
194 MaxRetentionSec=1month
199 services.physlock = {
202 # NOTE: xfconf-query -c xfce4-session -p /general/LockCommand -s "physlock" --create -t string
204 services.printing = {
213 # Allow members of the "adbusers" group to mount Android devices via MTP
214 pkgs.android-udev-rules
220 xkbOptions = "eurosign:e";
221 libinput.enable = true;
226 #pkgs.xfce.thunar-archive-plugin
229 xterm.enable = false;
232 defaultSession = "xfce";
235 user = users.sevy.name;
240 virtualisation.virtualbox.host.enable = true;
242 # This value determines the NixOS release with which your system is to be
243 # compatible, in order to avoid breaking some software such as database
244 # servers. You should change this only after NixOS release notes say you should.
245 system.stateVersion = "20.03"; # Did you read the comment?