9 ../nixos/profiles/graphical.nix
10 ../nixos/profiles/lang-fr.nix
11 ../nixos/profiles/laptop.nix
12 ../nixos/profiles/printing.nix
13 ../nixos/profiles/home.nix
20 # Lower kernel's security for better performances
21 security.kernel.mitigations = "off";
23 home-manager.users.sevy = {
24 imports = [ ../homes/sevy.nix ];
29 # Put the hashedPassword in /nix/store, but it will also be in /etc/passwd
30 # which is already world readable.
31 hashedPassword = lib.readFile patate/users/sevy/login/hashedPassword.clear;
34 config.services.davfs2.davGroup
49 #"ssh://nix-ssh@losurdo.wg?priority=30"
50 #"ssh://nix-ssh@oignon.wg?priority=10"
52 trusted-public-keys = map lib.readFile [
53 ../users/root/nix/losurdo.pub
54 ../users/root/nix/oignon.pub
59 environment.systemPackages = [
60 pkgs.riseup-vpn # Can't be installed by home-manager because it needs to install policy-kit rules
71 services.displayManager = {
72 defaultSession = "mate";
74 user = config.users.users.sevy.name;
78 virtualisation.virtualbox.host.enable = true;
80 # This value determines the NixOS release with which your system is to be
81 # compatible, in order to avoid breaking some software such as database
82 # servers. You should change this only after NixOS release notes say you should.
83 system.stateVersion = "20.03"; # Did you read the comment?